summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_6.1.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2023-05-31 14:48:58 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-06-01 08:07:51 +0100
commit7aad4c963c05a2ea987fdccf4e82e47a39226db8 (patch)
tree4d3af16deea53840750363bb5eeb6bd4d8f692ef /meta/recipes-kernel/linux/linux-yocto_6.1.bb
parent4fafe2da01b75afb062dc6e23cb4714b7f35a0fc (diff)
downloadpoky-7aad4c963c05a2ea987fdccf4e82e47a39226db8.tar.gz
linux-yocto: move build / debug dependencies to .inc
When the architecture and debug specific build and runtime dependencies were introduced, they were only applicable to "newer" kernel versions and were enabled in the version specific recipes. These are now common dependencies, so we can avoid the duplication and move them to a common location. We also change the adhoc nature of the existing elfutils definition, as it is now detected by the kernel build and we no longer need the work around to the native sysroot. Finally, we change the undocumented KERNEL_DEBUG_OPTIONS to KERNEL_DEBUG and use it to conditionally enable features that need extended support (and support sometimes out of oe-core). (From OE-Core rev: 7ddeb149e7a78bedeb945898fec5e8f13b7c5711) Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_6.1.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_6.1.bb4
1 files changed, 0 insertions, 4 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_6.1.bb b/meta/recipes-kernel/linux/linux-yocto_6.1.bb
index 7600f45522..7e7edf82c3 100644
--- a/meta/recipes-kernel/linux/linux-yocto_6.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_6.1.bb
@@ -46,10 +46,6 @@ SRC_URI += "file://0001-perf-cpumap-Make-counter-as-unsigned-ints.patch"
46LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" 46LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
47LINUX_VERSION ?= "6.1.27" 47LINUX_VERSION ?= "6.1.27"
48 48
49DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
50DEPENDS += "openssl-native util-linux-native"
51DEPENDS += "gmp-native libmpc-native"
52
53PV = "${LINUX_VERSION}+git${SRCPV}" 49PV = "${LINUX_VERSION}+git${SRCPV}"
54 50
55KMETA = "kernel-meta" 51KMETA = "kernel-meta"