summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_3.8.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-06-18 11:20:01 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-18 17:33:16 +0100
commitfe77047364eac502904a33bcbc35a704be9acc9e (patch)
tree5790b6fedbaba02dc590a2b170ac634e7f4a65a7 /meta/recipes-kernel/linux/linux-yocto_3.8.bb
parent2bdfdfe29bc93ae418010e65594e77d5100e7a02 (diff)
downloadpoky-fe77047364eac502904a33bcbc35a704be9acc9e.tar.gz
linux-yocto/3.8: fix gcc 4.8 ARM boot issues
Updating the linux-yocto-3.8 SRCREVs to fix a boot issue with ARM boards when gcc 4.8 is used. Without the following mainline backports: f200475 ARM: 7670/1: fix the memset fix 8215b0e ARM: 7668/1: fix memset-related crashes caused by recent GCC (4.7.2) optimizations The following trap will be seen on boot: [<c00fc3b8>] (kmem_cache_alloc_trace+0x54/0x210) from [<c039f074>] (con_insert_unipair+0xcc/0x11c) [<c039f074>] (con_insert_unipair+0xcc/0x11c) from [<c039fec8>] (con_set_default_unimap+0xfc/0x198) [<c039fec8>] (con_set_default_unimap+0xfc/0x198) from [<c07ee258>] (console_map_init+0x44/0x58) [<c07ee258>] (console_map_init+0x44/0x58) from [<c07ee738>] (vty_init+0x16c/0x1b0) [<c07ee738>] (vty_init+0x16c/0x1b0) from [<c07edb68>] (tty_init+0x108/0x148) [<c07edb68>] (tty_init+0x108/0x148) from [<c07eead0>] (chr_dev_init+0xb4/0xd8) [<c07eead0>] (chr_dev_init+0xb4/0xd8) from [<c0008a18>] (do_one_initcall+0x11c/0x18c) [<c0008a18>] (do_one_initcall+0x11c/0x18c) from [<c07d89d0>] (kernel_init_freeable+0x16c/0x254) [<c07d89d0>] (kernel_init_freeable+0x16c/0x254) from [<c05a3810>] (kernel_init+0x18/0x160) [<c05a3810>] (kernel_init+0x18/0x160) from [<c000e530>] (ret_from_fork+0x14/0x20) Code: e593a000 e35a0000 0a000020 e5943014 (e79a1003) ---[ end trace e6c62de166779f86 ]--- Kernel panic - not syncing: Attempted to kill init! exitcode=0x0000000b Moderate stress and board testing shows the fix to hold, and it is good for broader testing. [YOCTO #4549] (From OE-Core rev: 8ef393bc08a20053765ad58c1ebd9ab621cdd704) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_3.8.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.8.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.8.bb b/meta/recipes-kernel/linux/linux-yocto_3.8.bb
index 1517f4007c..0c21f7b25f 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.8.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.8.bb
@@ -3,13 +3,13 @@ require recipes-kernel/linux/linux-yocto.inc
3KBRANCH_DEFAULT = "standard/base" 3KBRANCH_DEFAULT = "standard/base"
4KBRANCH = "${KBRANCH_DEFAULT}" 4KBRANCH = "${KBRANCH_DEFAULT}"
5 5
6SRCREV_machine_qemuarm ?= "e267fe88798892416828d89bde7f778380b87a90" 6SRCREV_machine_qemuarm ?= "aa76cc28408376814752bd36fb0dcf0e25aa5ba3"
7SRCREV_machine_qemumips ?= "813bae2e17db9310f220935e87d168c8e52fafaf" 7SRCREV_machine_qemumips ?= "aa0affda03c955678b26b2fb586f1d9505127871"
8SRCREV_machine_qemuppc ?= "f90923775f9bcec3ce23246e8fb59d8f9551e566" 8SRCREV_machine_qemuppc ?= "698eada61d9385b42dd117858b943655b565084b"
9SRCREV_machine_qemux86 ?= "1f973c0fc8eea9a8f9758f47cf689ba89dbe9a25" 9SRCREV_machine_qemux86 ?= "f20047520a57322f05d95a18a5fbd082fb15cb87"
10SRCREV_machine_qemux86-64 ?= "1f973c0fc8eea9a8f9758f47cf689ba89dbe9a25" 10SRCREV_machine_qemux86-64 ?= "f20047520a57322f05d95a18a5fbd082fb15cb87"
11SRCREV_machine ?= "1f973c0fc8eea9a8f9758f47cf689ba89dbe9a25" 11SRCREV_machine ?= "f20047520a57322f05d95a18a5fbd082fb15cb87"
12SRCREV_meta ?= "edd6461602f6c2fc27bc72997e4437f422a9dccd" 12SRCREV_meta ?= "c0851dfb8535635e1e31d4a5146d3f021e30506c"
13 13
14SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.8.git;protocol=git;bareclone=1;branch=${KBRANCH},${KMETA};name=machine,meta" 14SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.8.git;protocol=git;bareclone=1;branch=${KBRANCH},${KMETA};name=machine,meta"
15 15