summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_3.8.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-02-25 03:51:34 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-02 22:45:27 +0000
commit68e1c567882538c3e183d0863ab87f19431efcea (patch)
tree6fb683c9f2e1e59fe7ee2d22cf5a7f0a55d3c333 /meta/recipes-kernel/linux/linux-yocto_3.8.bb
parentd756b3ffaf93b67eed3cdfe45470d6121af8c341 (diff)
downloadpoky-68e1c567882538c3e183d0863ab87f19431efcea.tar.gz
linux-yocto: introduce 3.8 kernel recipe
Introducing the linux-yocto 3.8 kernel recipe. The tools and branch structure of this tree are the same as the previous linux-yocto recipes, while the meta data and content have been updated for the 3.8 kernel. build and boot tested for qemu*. (From OE-Core rev: ecf287a80c5ace2c440f8d0089934d59d25dc3ec) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_3.8.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.8.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.8.bb b/meta/recipes-kernel/linux/linux-yocto_3.8.bb
new file mode 100644
index 0000000000..7c1dff768f
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto_3.8.bb
@@ -0,0 +1,30 @@
1require recipes-kernel/linux/linux-yocto.inc
2
3KBRANCH_DEFAULT = "standard/base"
4KBRANCH = "${KBRANCH_DEFAULT}"
5
6SRCREV_machine_qemuarm ?= "351d133943b50a9dfeee07661d44254722a19f04"
7SRCREV_machine_qemumips ?= "d529d082041142435587bd442b1235dbe1c72950"
8SRCREV_machine_qemuppc ?= "8dcd155ad408658e9180d1630da2ac7e0ee70542"
9SRCREV_machine_qemux86 ?= "b170394a475b96ecc92cbc9e4b002bed0a9f69c5"
10SRCREV_machine_qemux86-64 ?= "b170394a475b96ecc92cbc9e4b002bed0a9f69c5"
11SRCREV_machine ?= "b170394a475b96ecc92cbc9e4b002bed0a9f69c5"
12SRCREV_meta ?= "c2ed0f16fdec628242a682897d5d86df4547cf24"
13
14SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.8.git;protocol=git;bareclone=1;branch=${KBRANCH},${KMETA};name=machine,meta"
15
16LINUX_VERSION ?= "3.8"
17
18PR = "${INC_PR}.0"
19PV = "${LINUX_VERSION}+git${SRCPV}"
20
21KMETA = "meta"
22
23COMPATIBLE_MACHINE = "qemuarm|qemux86|qemuppc|qemumips|qemux86-64"
24
25# Functionality flags
26KERNEL_FEATURES_append = " features/netfilter/netfilter.scc"
27KERNEL_FEATURES_append_qemux86=" cfg/sound.scc"
28KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"
29KERNEL_FEATURES_append_qemux86=" cfg/paravirt_kvm.scc"
30KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"