summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_3.2.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2012-06-07 15:59:46 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-08 11:56:31 +0100
commit9cf85014444a55ecfd2bd794ff267f68fa216928 (patch)
tree7c8186364190f9c2fb4d10081968bf79a3747576 /meta/recipes-kernel/linux/linux-yocto_3.2.bb
parentb0789103afd51fb74b8dd47e0b5584f65c96b90c (diff)
downloadpoky-9cf85014444a55ecfd2bd794ff267f68fa216928.tar.gz
linux-yocto: add machine aliases for yocto BSPs
To avoid mapping machine names to kernel machine names in recipes, we can define multiple KMACHINE names for a single in tree board. This allows the tools to match a board description to multiple different MACHINEs. As a result, we can remove the explicit KMACHINE mappings from the linux-yocto recipes and allow the KMACHINE=${MACHINE} default to handle mappings. Individual recipes an bbappends can override this as required. (From OE-Core rev: d3dc05a4b808136876cb257a568737abfaceeadd) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_3.2.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.2.bb9
1 files changed, 1 insertions, 8 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.2.bb b/meta/recipes-kernel/linux/linux-yocto_3.2.bb
index 665ddca053..ac4e454702 100644
--- a/meta/recipes-kernel/linux/linux-yocto_3.2.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_3.2.bb
@@ -1,13 +1,6 @@
1inherit kernel 1inherit kernel
2require recipes-kernel/linux/linux-yocto.inc 2require recipes-kernel/linux/linux-yocto.inc
3 3
4KMACHINE = "common-pc"
5KMACHINE_qemux86 = "common-pc"
6KMACHINE_qemux86-64 = "common-pc-64"
7KMACHINE_qemuppc = "qemu-ppc32"
8KMACHINE_qemumips = "mti-malta32-be"
9KMACHINE_qemuarm = "arm-versatile-926ejs"
10
11KBRANCH = "standard/default/base" 4KBRANCH = "standard/default/base"
12KBRANCH_qemux86 = "standard/default/common-pc/base" 5KBRANCH_qemux86 = "standard/default/common-pc/base"
13KBRANCH_qemux86-64 = "standard/default/common-pc-64/base" 6KBRANCH_qemux86-64 = "standard/default/common-pc-64/base"
@@ -23,7 +16,7 @@ SRCREV_machine_qemuppc ?= "466746d1fe6370957ba087f9ca6f2e31201b2162"
23SRCREV_machine_qemux86 ?= "c228cadee60f0ada73d11a36f6932f50a1c52d48" 16SRCREV_machine_qemux86 ?= "c228cadee60f0ada73d11a36f6932f50a1c52d48"
24SRCREV_machine_qemux86-64 ?= "b95a0ae3773545fa0ed9a47088d0361527c42e6c" 17SRCREV_machine_qemux86-64 ?= "b95a0ae3773545fa0ed9a47088d0361527c42e6c"
25SRCREV_machine ?= "8b8cfaaab2b8d79ac56e8c9a85bad9ae7bca399c" 18SRCREV_machine ?= "8b8cfaaab2b8d79ac56e8c9a85bad9ae7bca399c"
26SRCREV_meta ?= "49f931bc294d5b6be60502bbd448cff5aa766235" 19SRCREV_meta ?= "0a18db9fc89a0e030e8c7b8d01fe03c5ca4197e3"
27 20
28PR = "r1" 21PR = "r1"
29PV = "${LINUX_VERSION}+git${SRCPV}" 22PV = "${LINUX_VERSION}+git${SRCPV}"