summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_3.10.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-08-23 14:08:20 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-08-26 11:29:45 +0100
commit388318706699250b7f48c5692ba81f0595b176bd (patch)
tree475535310cb12d599a55e584b0eafb0f537f0019 /meta/recipes-kernel/linux/linux-yocto_3.10.bb
parent2c572bd2cea665d6c048449e25b18791e3be52fb (diff)
downloadpoky-388318706699250b7f48c5692ba81f0595b176bd.tar.gz
linux-yocto: introduce v3.10
Introduce the 3.10 kernel. This is based on the 3.10.9 upstream kernel and replaces the 3.8 recipes, which will be removed once all reference boards have been updated. 3.10 also the latest LTSI and will be updated with that content when it becomes available. Other features of the 3.10 kernel include: - refreshed -rt support - refreshed yaffs2, aufs3 - cryptodev - bfs, edf, and OCF staged features - scrubbed and updated meta data for v3.10 - improved tools support for meta data updates and queue maintenance - patch carry forward from all previous linux-yocto kernels and configuration. This kernel has been built and boot tested on all qemu machines and architectures. (From OE-Core rev: 6dc46834c6edaf358c18b26e4304bc9e7413eb60) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_3.10.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_3.10.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_3.10.bb b/meta/recipes-kernel/linux/linux-yocto_3.10.bb
new file mode 100644
index 0000000000..ea6ad2a74d
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto_3.10.bb
@@ -0,0 +1,30 @@
1require recipes-kernel/linux/linux-yocto.inc
2
3KBRANCH_DEFAULT = "standard/base"
4KBRANCH = "${KBRANCH_DEFAULT}"
5
6SRCREV_machine_qemuarm ?= "8675d3d0a3c17135f70ef474d5c362397c02e62a"
7SRCREV_machine_qemumips ?= "992b743b905edd21d3a4a27c92b5c6a9e44d7d73"
8SRCREV_machine_qemuppc ?= "09388c3572e26c78b34554e46e077f12be7b2401"
9SRCREV_machine_qemux86 ?= "6c1528b2b78d1ec7e75bb7a9880074ec35aa1aa0"
10SRCREV_machine_qemux86-64 ?= "6c1528b2b78d1ec7e75bb7a9880074ec35aa1aa0"
11SRCREV_machine_qemumips64 ?= "203679cb23c752fdcbc0180a55a81728d7462561"
12SRCREV_machine ?= "6c1528b2b78d1ec7e75bb7a9880074ec35aa1aa0"
13SRCREV_meta ?= "1b9b113837f353fd94148beb6bd00a3b7b35d01d"
14
15SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.10.git;protocol=git;bareclone=1;branch=${KBRANCH},${KMETA};name=machine,meta"
16
17LINUX_VERSION ?= "3.10.9"
18
19PV = "${LINUX_VERSION}+git${SRCPV}"
20
21KMETA = "meta"
22
23COMPATIBLE_MACHINE = "qemuarm|qemux86|qemuppc|qemumips|qemumips64|qemux86-64"
24
25# Functionality flags
26KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc"
27KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
28KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
29KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"
30KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"