summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2011-06-08 15:33:02 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-06-14 15:22:56 +0100
commitdcfb6e4d2ab5df32f0f2408a1aafd6923018555f (patch)
treefd51af5ce705ddbbce3adb6e8a088c0754c1b7ec /meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
parent9031e7e16f54e818b5e7c2d46ef720fd0f8c2cfa (diff)
downloadpoky-dcfb6e4d2ab5df32f0f2408a1aafd6923018555f.tar.gz
linux-yocto: rename recipes to explicitly indicate version
The existing recipe names for the linux-yocto kernel builds worked well when there was a single, or two versions of the kernel available. But with the impending kernel updates and retirement of older kernels, the re-use of the same recipes for different kernel versions violates the principle of least surprise. To address this, the recipes are being renamed as follows: linux-yocto_git.bb -> linux-yocto_2.6.37.bb linux-yocto-stable_git.bb -> linux-yocto_2.6.34.bb There continue to be versionless recipe names that feed into versioned recipes at the appropriate points. They are: linux-yocto-dev.bb (tracking the latest yocto dev kernel) linux-yocto-korg_head.bb (tracking korg kernels) There are no existing users of linux-yocto-stable in the master branches to convert to the new naming, so these changes work in isolation. (From OE-Core rev: 576c87349a72a94357014ff29f55db692903ed80) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_2.6.37.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_2.6.37.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb b/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
new file mode 100644
index 0000000000..1d43e1e381
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
@@ -0,0 +1,46 @@
1inherit kernel
2require linux-yocto.inc
3
4KMACHINE = "yocto/standard/base"
5KMACHINE_qemux86 = "yocto/standard/common-pc/base"
6KMACHINE_qemux86-64 = "yocto/standard/common-pc-64/base"
7KMACHINE_qemuppc = "yocto/standard/qemu-ppc32"
8KMACHINE_qemumips = "yocto/standard/mti-malta32-be"
9KMACHINE_qemuarm = "yocto/standard/arm-versatile-926ejs"
10
11KBRANCH = ${KMACHINE}
12KMETA = meta
13
14LINUX_VERSION ?= "2.6.37"
15LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE}"
16
17SRCREV_machine_qemuarm = "2070a54dbde57d2987c832a016b05949f7e6e086"
18SRCREV_machine_qemumips = "bd9eab8e382e11dc08a5de8b010570f03de949e5"
19SRCREV_machine_qemuppc = "704497b3a48c0882078f6167277d65d932292535"
20SRCREV_machine_qemux86 = "c1a74a7872fdd1152265087aa7e59b96a8f2f42a"
21SRCREV_machine_qemux86-64 = "1950ea205407d8950475a37404173572d55fd27f"
22SRCREV_machine = "697d84759be192403a8a87ab269196c67a0c2c88"
23SRCREV_meta = "f1dc3722d45cdcc92c84ebfecf4ce616d2efed26"
24
25PR = "r18"
26PV = "${LINUX_VERSION}+git${SRCPV}"
27SRCREV_FORMAT = "meta_machine"
28
29SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.37;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
30
31COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
32
33# Functionality flags
34KERNEL_REVISION_CHECKING ?= "t"
35KERNEL_FEATURES="features/netfilter"
36KERNEL_FEATURES_append_qemux86=" cfg/sound"
37KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
38
39YOCTO_KERNEL_META_DATA=t
40
41# extra tasks
42addtask kernel_link_vmlinux after do_compile before do_install
43addtask validate_branches before do_patch after do_kernel_checkout
44addtask kernel_configcheck after do_configure before do_compile
45
46require linux-tools.inc