summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2011-09-09 18:27:46 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-09-15 11:23:57 +0100
commit1080d52f578ca03a48569c638ea72f53bdaf4cc7 (patch)
tree21b91bdf49f3e41cdc12348fd81f1562d6f4c813 /meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
parent8c310ee0a94a7e15d815a2719272ffc704e857b0 (diff)
downloadpoky-1080d52f578ca03a48569c638ea72f53bdaf4cc7.tar.gz
linux-yocto: move common tasks to a common location
During the initial development of the linux-yocto recipes there were several additional tasks that needed to be run in any inheriting recipe. At that time, they didn't seem to fire if they were in the include file versus the recipes themselves. As it turns out, these tasks do work fine if placed in the linux-yocto.inc file, and the rest of the recipes can be simplified as a result. (From OE-Core rev: a1ab7c5e03df97e630dfee470ff7959d3143bf41) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_2.6.37.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_2.6.37.bb13
1 files changed, 1 insertions, 12 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb b/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
index 419913728a..34e563cffd 100644
--- a/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_2.6.37.bb
@@ -9,10 +9,8 @@ KMACHINE_qemumips = "yocto/standard/mti-malta32-be"
9KMACHINE_qemuarm = "yocto/standard/arm-versatile-926ejs" 9KMACHINE_qemuarm = "yocto/standard/arm-versatile-926ejs"
10 10
11KBRANCH = ${KMACHINE} 11KBRANCH = ${KMACHINE}
12KMETA = meta
13 12
14LINUX_VERSION ?= "2.6.37" 13LINUX_VERSION ?= "2.6.37"
15LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE}"
16 14
17SRCREV_machine_qemuarm = "b3e53a090eaa23aa82e64fa0a563a93a2b4dbb5d" 15SRCREV_machine_qemuarm = "b3e53a090eaa23aa82e64fa0a563a93a2b4dbb5d"
18SRCREV_machine_qemumips = "91f2eb4a3b447476b36aac8e6e198d08c98e0680" 16SRCREV_machine_qemumips = "91f2eb4a3b447476b36aac8e6e198d08c98e0680"
@@ -22,26 +20,17 @@ SRCREV_machine_qemux86-64 = "af2bfbe5f757361b5b027a24d67a93bfdfaaf33c"
22SRCREV_machine = "4ae8f8605c81c39b959948e23f7123294a5dfb3f" 20SRCREV_machine = "4ae8f8605c81c39b959948e23f7123294a5dfb3f"
23SRCREV_meta = "aeea99683c7283f1f3320bf2ee7085ee252d4e7e" 21SRCREV_meta = "aeea99683c7283f1f3320bf2ee7085ee252d4e7e"
24 22
25PR = "r20" 23PR = "r21"
26PV = "${LINUX_VERSION}+git${SRCPV}" 24PV = "${LINUX_VERSION}+git${SRCPV}"
27SRCREV_FORMAT = "meta_machine"
28 25
29SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.37;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta" 26SRC_URI = "git://git.yoctoproject.org/linux-yocto-2.6.37;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
30 27
31COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)" 28COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
32 29
33# Functionality flags 30# Functionality flags
34KERNEL_REVISION_CHECKING ?= "t"
35KERNEL_FEATURES="features/netfilter" 31KERNEL_FEATURES="features/netfilter"
36KERNEL_FEATURES_append=" features/taskstats" 32KERNEL_FEATURES_append=" features/taskstats"
37KERNEL_FEATURES_append_qemux86=" cfg/sound" 33KERNEL_FEATURES_append_qemux86=" cfg/sound"
38KERNEL_FEATURES_append_qemux86-64=" cfg/sound" 34KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
39 35
40YOCTO_KERNEL_META_DATA=t
41
42# extra tasks
43addtask kernel_link_vmlinux after do_compile before do_install
44addtask validate_branches before do_patch after do_kernel_checkout
45addtask kernel_configcheck after do_configure before do_compile
46
47require linux-tools.inc 36require linux-tools.inc