summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei.gherzan@huawei.com>2022-08-25 19:59:15 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-08-30 10:33:35 +0100
commit114d4048c182557f64e5d575742d622e191bed14 (patch)
tree119292d96a07f96d50575531919bc3f322999082 /meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
parentf941dad9d723ead66b88b9905c40c4fbe7002936 (diff)
downloadpoky-114d4048c182557f64e5d575742d622e191bed14.tar.gz
linux-yocto: Fix COMPATIBLE_MACHINE regex match
With the current regex expression, a machine that is not part of the compatible could match the regex expression. For example, consider the following COMPATIBLE_MACHINE: COMPATIBLE_MACHINE = "qemuarm|qemuarm64" A machine definition bringing in "qemuarm-foo" would match against the COMPATIBLE_MACHINE pattern above (see base.bbclass for implementation details). Fix this by matching the start and the end of the string. (From OE-Core rev: 63db2c6baadb4b9aa0c8ae82a497f30840b3b347) Signed-off-by: Andrei Gherzan <andrei.gherzan@huawei.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
index f1b6f98c77..2de32ffecd 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
@@ -22,7 +22,7 @@ PV = "${LINUX_VERSION}+git${SRCPV}"
22SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \ 22SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
23 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.15;destsuffix=${KMETA}" 23 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.15;destsuffix=${KMETA}"
24 24
25COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm64|qemuarm|qemuarmv5" 25COMPATIBLE_MACHINE = "^(qemux86|qemux86-64|qemuarm64|qemuarm|qemuarmv5)$"
26 26
27# Functionality flags 27# Functionality flags
28KERNEL_FEATURES = "" 28KERNEL_FEATURES = ""