summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-12-17 13:08:10 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-01-05 13:48:41 +0000
commit5093ecb7ffeb5dc7537c49b51fe900b2f7df2826 (patch)
tree4070e5e4e806511a17c3efb43c368743a77eb807 /meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
parente40068655827745d73111a57a8b659252d98dca8 (diff)
downloadpoky-5093ecb7ffeb5dc7537c49b51fe900b2f7df2826.tar.gz
linux-yocto: introduce v5.10 reference kernel recipes
The 5.10 kernel will replace 5.8 as the reference kernel for the next release. With this commit, we add standard/tiny/rt support for that kernel across all of the supported architectures and qemu reference machines. (From OE-Core rev: 74c5b98979172c0057883568df453da019abe235) Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
new file mode 100644
index 0000000000..360273b979
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.10.bb
@@ -0,0 +1,32 @@
1KBRANCH ?= "v5.10/standard/tiny/base"
2KBRANCH_qemuarm ?= "v5.10/standard/tiny/arm-versatile-926ejs"
3
4LINUX_KERNEL_TYPE = "tiny"
5KCONFIG_MODE = "--allnoconfig"
6
7require recipes-kernel/linux/linux-yocto.inc
8
9LINUX_VERSION ?= "5.10.1"
10LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46"
11
12DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
13DEPENDS += "openssl-native util-linux-native"
14
15KMETA = "kernel-meta"
16KCONF_BSP_AUDIT_LEVEL = "2"
17
18SRCREV_machine_qemuarm ?= "24ca6a279d74e25bd07323bb901614d77e88fa2c"
19SRCREV_machine ?= "77592e956cc9cf420b17381e1b43f116395d37b3"
20SRCREV_meta ?= "1c2727e4bf30f06e6135ef59999b53cf465f6371"
21
22PV = "${LINUX_VERSION}+git${SRCPV}"
23
24SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
25 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.10;destsuffix=${KMETA}"
26
27COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm|qemuarmv5"
28
29# Functionality flags
30KERNEL_FEATURES = ""
31
32KERNEL_DEVICETREE_qemuarmv5 = "versatile-pb.dtb"