summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_4.10.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2017-02-26 22:10:02 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-04 23:18:16 +0000
commitd2b776f34d1b030342622765c94e799dcf5cfaec (patch)
treeb7fd93c0e20a098de3872cc05289f6c0275c36d8 /meta/recipes-kernel/linux/linux-yocto-tiny_4.10.bb
parent2e5181e510f3fffee53cfeab0380e8ad9b5ae60c (diff)
downloadpoky-d2b776f34d1b030342622765c94e799dcf5cfaec.tar.gz
linux-yocto: introduce 4.10 recipes
The 4.10 kernel has been released, so we introduce the linux-yocto variant. This version supercedes the 4.4 and 4.8 versions in the tree, leaving us with 4.1 (LTSI), 4.9 (LTS) and 4.10 (most recent) as the three active versions. Build tested against all qemu variants, core-image-kernel-dev + sato, with musl and glibc as the C libraries. (From OE-Core rev: e8f07d2966a3fc6cfc6466020dc6603a84fe33da) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_4.10.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.10.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.10.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.10.bb
new file mode 100644
index 0000000000..4d4639a97f
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.10.bb
@@ -0,0 +1,25 @@
1KBRANCH ?= "standard/tiny/common-pc"
2LINUX_KERNEL_TYPE = "tiny"
3KCONFIG_MODE = "--allnoconfig"
4
5require recipes-kernel/linux/linux-yocto.inc
6
7LINUX_VERSION ?= "4.10"
8
9KMETA = "kernel-meta"
10KCONF_BSP_AUDIT_LEVEL = "2"
11
12SRCREV_machine ?= "b259a5d744e8955a03405c6b59c5a61724755ea8"
13SRCREV_meta ?= "805ea440c791acee4617820ab32e93f1ccbd9ae2"
14
15PV = "${LINUX_VERSION}+git${SRCPV}"
16
17SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.10.git;branch=${KBRANCH};name=machine \
18 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.10;destsuffix=${KMETA}"
19
20COMPATIBLE_MACHINE = "(qemux86$)"
21
22# Functionality flags
23KERNEL_FEATURES = ""
24
25KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"