summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2016-05-27 12:18:35 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-30 15:58:15 +0100
commit2b82b59fb21ec12a12f64fcc53dfe52caa2eb28b (patch)
tree77a7548430eeae831691ce6c1a7345c5a8425421 /meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
parent5224ac7e95057c724e66f162e5bad6779c0a417d (diff)
downloadpoky-2b82b59fb21ec12a12f64fcc53dfe52caa2eb28b.tar.gz
linux-yocto/4.1: fix musb compilation error
We had a partial musb change merged into the 4.1 tree, which resulted in: | kernel-source/drivers/usb/musb/musb_dsps.c: In function 'dsps_create_musb_pdev': | kernel-source/drivers/usb/musb/musb_dsps.c:750:8: error: 'struct musb_hdrc_config' has no member named 'maximum_speed' | config->maximum_speed = usb_get_maximum_speed(&parent->dev); | ^~ By backporting commit: 9b7537642cb6a [usb: musb: set the controller speed based on the config setting] We get our missing structure field, and we can once again build musb. [YOCTO: #9680] (From OE-Core rev: b746223787a0195c3a4d16523003c62ec0ac8451) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
index 9757c4d020..bf7d6c5959 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.1.bb
@@ -9,7 +9,7 @@ LINUX_VERSION ?= "4.1.24"
9KMETA = "kernel-meta" 9KMETA = "kernel-meta"
10KCONF_BSP_AUDIT_LEVEL = "2" 10KCONF_BSP_AUDIT_LEVEL = "2"
11 11
12SRCREV_machine ?= "ecc983477682203619da0e456fa4a8689ac41097" 12SRCREV_machine ?= "403eda4633e9037fb715d0d1e8ae847b2bd0651a"
13SRCREV_meta ?= "4b4199bd24f206d459061bb0a920d009429d5ed3" 13SRCREV_meta ?= "4b4199bd24f206d459061bb0a920d009429d5ed3"
14 14
15PV = "${LINUX_VERSION}+git${SRCPV}" 15PV = "${LINUX_VERSION}+git${SRCPV}"