summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_3.17.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-09-08 00:21:21 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-09-10 15:38:56 +0100
commit4a82041d8a36fdce89ca48bf292a85491fb4a033 (patch)
tree431d2ee76538a9a0317d43ea166b4974add9d2c3 /meta/recipes-kernel/linux/linux-yocto-tiny_3.17.bb
parent6cb383cab897b2d3cdcb109a161c1de9e0135e3b (diff)
downloadpoky-4a82041d8a36fdce89ca48bf292a85491fb4a033.tar.gz
linux-yocto: introduce v3.17
With this commit, we introduce the v3.17-rcX kernels, which will be released as part of the 1.7 yocto project. All architectures have been compiled and booted with this revision of the kernel. (From OE-Core rev: 07315861450ebf3cd224f4700eb125b74057aa0f) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_3.17.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.17.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.17.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.17.bb
new file mode 100644
index 0000000000..c1cb47ba90
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.17.bb
@@ -0,0 +1,21 @@
1KBRANCH ?= "standard/tiny/base"
2LINUX_KERNEL_TYPE = "tiny"
3KCONFIG_MODE = "--allnoconfig"
4
5require recipes-kernel/linux/linux-yocto.inc
6
7LINUX_VERSION ?= "3.17-rc4"
8
9KMETA = "meta"
10
11SRCREV_machine ?= "1a3939eb747a635b23b4234f785795c52dce72a8"
12SRCREV_meta ?= "7df849fc7eba54765368e26634341dbe6e2ad161"
13
14PV = "${LINUX_VERSION}+git${SRCPV}"
15
16SRC_URI = "git://git.yoctoproject.org/linux-yocto-dev.git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
17
18COMPATIBLE_MACHINE = "(qemux86)"
19
20# Functionality flags
21KERNEL_FEATURES = ""