summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2014-03-31 13:56:29 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-31 23:04:35 +0100
commit3746a51f469bba3de921d9696aea672191f1ebbb (patch)
tree5e91fdb87013b90b5bf2b7e54c40bad8579eeedc /meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
parent0906266cd3c71e782837ce80677d9e2e0732715b (diff)
downloadpoky-3746a51f469bba3de921d9696aea672191f1ebbb.tar.gz
linux-yocto/3.14: introduce versioned recipes
The release kernel for Yocto 1.6 is the 3.14 kernel, so we introduce the versioned recipes here. (From OE-Core rev: 92776093766d4b0bb2613214274fa28dc59b6126) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
new file mode 100644
index 0000000000..2e142bfd90
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.14.bb
@@ -0,0 +1,21 @@
1require recipes-kernel/linux/linux-yocto.inc
2
3KBRANCH = "standard/tiny/base"
4LINUX_KERNEL_TYPE = "tiny"
5KCONFIG_MODE = "--allnoconfig"
6
7LINUX_VERSION ?= "3.14"
8
9KMETA = "meta"
10
11SRCREV_machine ?= "0143c6ebb4a2d63b241df5f608b19f483f7eb9e0"
12SRCREV_meta ?= "fc8c30398dbc3cdea787a1042242d4aab689d0ae"
13
14PV = "${LINUX_VERSION}+git${SRCPV}"
15
16SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.14.git;bareclone=1;branch=${KBRANCH},meta;name=machine,meta"
17
18COMPATIBLE_MACHINE = "(qemux86)"
19
20# Functionality flags
21KERNEL_FEATURES = ""