summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-12-14 15:13:57 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-03 12:14:28 +0000
commit95ba9b7d3003dfa99a2b866979189d1075227868 (patch)
tree420b64a3a96350d59665bd31b8acc054a7837fc4 /meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb
parentb5d6121bbb1186a1c36a29091f82501d3af6888a (diff)
downloadpoky-95ba9b7d3003dfa99a2b866979189d1075227868.tar.gz
linux-yocto-tiny: New kernel recipe for tiny distros
linux-yocto-tiny drops the linux-tools and sets the KMACHINE branch to standard/tiny. (From OE-Core rev: 8a76f80cabb8df5959707ee708f2c00b28a784e7) Signed-off-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb
new file mode 100644
index 0000000000..c5855a3576
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_3.0.bb
@@ -0,0 +1,36 @@
1inherit kernel
2require recipes-kernel/linux/linux-yocto.inc
3
4#KMACHINE = "yocto/standard/tiny/base"
5KMACHINE = "yocto/standard/base"
6KBRANCH = ${KMACHINE}
7
8LINUX_VERSION ?= "3.0.12"
9
10SRCREV_machine ?= "f389d310965a56091f688b28ea8be6d9cbb7fbbe"
11SRCREV_meta ?= "04a52a32cbdf0972033b97b83eaa83eb275dfdc9"
12
13PR = "r1"
14PV = "${LINUX_VERSION}+git${SRCPV}"
15
16SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.0;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta \
17 file://core.cfg \
18 file://serial.cfg \
19 file://ext2.cfg \
20 file://rtc-pc.cfg \
21 file://ramfs.cfg \
22 file://devtmpfs.cfg \
23 file://net.cfg \
24 file://debug.cfg \
25 file://lzma.cfg \
26 "
27
28
29# Enable qemux86 specific emulated options
30SRC_URI_append_qemux86 = " file://defconfig file://ata.cfg file://e1000.cfg"
31
32#COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64)"
33COMPATIBLE_MACHINE = "(qemux86)"
34
35# Functionality flags
36KERNEL_FEATURES=""