summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_5.4.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2021-08-15 11:08:57 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-18 17:01:06 +0100
commit1ce72e983c2b0c5509289388a93a139eb0eec1a9 (patch)
treee9df7419548066c78c61a13197a593ca01913c3c /meta/recipes-kernel/linux/linux-yocto-rt_5.4.bb
parentf557bdbf1dcc74a9acd9377f7b665a3dc2afc496 (diff)
downloadpoky-1ce72e983c2b0c5509289388a93a139eb0eec1a9.tar.gz
linux-yocto/5.4: remove recipes
We have 5.10 and 5.13 as the active recipes in the release/development branches, so we remove 5.4. This leaves us with the standard three versions for release (5.10, 5.13 and -dev). 5.4 will continue to be updated in stable/supported releases. (From OE-Core rev: f4ff7a501df84f15900652703349c0072ef8714c) Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_5.4.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_5.4.bb45
1 files changed, 0 insertions, 45 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_5.4.bb b/meta/recipes-kernel/linux/linux-yocto-rt_5.4.bb
deleted file mode 100644
index 405f51d649..0000000000
--- a/meta/recipes-kernel/linux/linux-yocto-rt_5.4.bb
+++ /dev/null
@@ -1,45 +0,0 @@
1KBRANCH ?= "v5.4/standard/preempt-rt/base"
2
3require recipes-kernel/linux/linux-yocto.inc
4
5# Skip processing of this recipe if it is not explicitly specified as the
6# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
7# to build multiple virtual/kernel providers, e.g. as dependency of
8# core-image-rt-sdk, core-image-rt.
9python () {
10 if d.getVar("KERNEL_PACKAGE_NAME") == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-yocto-rt":
11 raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
12}
13
14SRCREV_machine ?= "0ad6f2204daf35fb25df5e9b52383507df813bb4"
15SRCREV_meta ?= "98ba88191b7c489bc0d83b6c87a31b2330fcd886"
16
17SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
18 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.4;destsuffix=${KMETA}"
19
20LINUX_VERSION ?= "5.4.139"
21
22LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
23
24DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
25DEPENDS += "openssl-native util-linux-native"
26
27PV = "${LINUX_VERSION}+git${SRCPV}"
28
29KMETA = "kernel-meta"
30KCONF_BSP_AUDIT_LEVEL = "2"
31
32LINUX_KERNEL_TYPE = "preempt-rt"
33
34COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuarm|qemuarmv5|qemuarm64|qemuppc|qemumips)"
35
36KERNEL_DEVICETREE:qemuarmv5 = "versatile-pb.dtb"
37
38# Functionality flags
39KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/taskstats/taskstats.scc"
40KERNEL_FEATURES:append = " ${KERNEL_EXTRA_FEATURES}"
41KERNEL_FEATURES:append:qemuall=" cfg/virtio.scc features/drm-bochs/drm-bochs.scc"
42KERNEL_FEATURES:append:qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
43KERNEL_FEATURES:append:qemux86-64=" cfg/sound.scc cfg/paravirt_kvm.scc"
44KERNEL_FEATURES:append = "${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/scsi/scsi-debug.scc", "", d)}"
45KERNEL_FEATURES:append = "${@bb.utils.contains("DISTRO_FEATURES", "ptest", " features/gpio/mockup.scc", "", d)}"