summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2017-09-14 09:46:57 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-17 23:23:21 +0100
commitc4c7be4c1d882ac245c5b666bc833e323adbf674 (patch)
treee0c006a703e4266e9804489d5be23ed32d955c48 /meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
parent311b80a180cd7e4de3ee590800d2203f4a268c32 (diff)
downloadpoky-c4c7be4c1d882ac245c5b666bc833e323adbf674.tar.gz
linux-yocto/4.4: update to v4.4.87
Integrating the -stable update with the following commits: 573b59e17e37 Linux 4.4.87 d95827490c39 crypto: algif_skcipher - only call put_page on referenced and used pages ab3ee6b53d67 epoll: fix race between ep_poll_callback(POLLFREE) and ep_free()/ep_remove() 628212c89fae kvm: arm/arm64: Force reading uncached stage2 PGD 57ff696f54b5 kvm: arm/arm64: Fix race in resetting stage2 PGD 94183009ac0e drm/ttm: Fix accounting error when fail to get pages for pool 9b3dcc98d8df xfrm: policy: check policy direction value c0c2e7567a34 wl1251: add a missing spin_lock_init() 5f08f0aebf70 CIFS: remove endian related sparse warning e596cc1454d4 CIFS: Fix maximum SMB2 header size 6cdda3497db8 alpha: uapi: Add support for __SANE_USERSPACE_TYPES__ ed48d9230e30 cpuset: Fix incorrect memory_pressure control file mapping 15e94ec4ec21 cpumask: fix spurious cpumask_of_node() on non-NUMA multi-node configs 857d0b3dd756 ceph: fix readpage from fscache 043ccc9781cc i2c: ismt: Return EMSGSIZE for block reads with bogus length fab3229af4e5 i2c: ismt: Don't duplicate the receive length for block reads e119fc492de9 irqchip: mips-gic: SYNC after enabling GIC region cd99a4f3f43b Linux 4.4.86 c81c4d453edf drm/i915: fix compiler warning in drivers/gpu/drm/i915/intel_uncore.c b7571624fe98 scsi: sg: reset 'res_in_use' after unlinking reserved array a4075bbb67b9 scsi: sg: protect accesses to 'reserved' page array 823086b057aa arm64: fpsimd: Prevent registers leaking across exec 218720fe5939 x86/io: Add "memory" clobber to insb/insw/insl/outsb/outsw/outsl a7a074f3a4d5 arm64: mm: abort uaccess retries upon fatal signal da981044d049 lpfc: Fix Device discovery failures during switch reboot test. 389328ea1379 p54: memset(0) whole array 5acdbe667cf4 lightnvm: initialize ppa_addr in dev_to_generic_addr() d255fffdb532 gcov: support GCC 7.1 2f3e97a814c8 gcov: add support for gcc version >= 6 41685ae5cd7b i2c: jz4780: drop superfluous init 05429bbfd726 btrfs: remove duplicate const specifier 9a64425945a0 ALSA: au88x0: Fix zero clear of stream->resources da8477a6695a scsi: isci: avoid array subscript warning (From OE-Core rev: 6b06a7ae93d7d98c03e7e924a434463a4337e47b) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
index b797dff25a..f808f9bb9c 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
@@ -11,13 +11,13 @@ python () {
11 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it") 11 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
12} 12}
13 13
14SRCREV_machine ?= "1ac44e48420edba265d0fa18e4040e6d975776e6" 14SRCREV_machine ?= "7c9e95ef538ddfed606500281e20c42bc1ac1ae0"
15SRCREV_meta ?= "8e9afd032ff3be672506a0e5ed51cde9dc45031f" 15SRCREV_meta ?= "804d2b3164ec25ed519fd695de9aa0908460c92e"
16 16
17SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;branch=${KBRANCH};name=machine \ 17SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;branch=${KBRANCH};name=machine \
18 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.4;destsuffix=${KMETA}" 18 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.4;destsuffix=${KMETA}"
19 19
20LINUX_VERSION ?= "4.4.85" 20LINUX_VERSION ?= "4.4.87"
21 21
22PV = "${LINUX_VERSION}+git${SRCPV}" 22PV = "${LINUX_VERSION}+git${SRCPV}"
23 23