summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-02-06 11:21:58 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-15 11:23:10 +0000
commit528835ba233341af2c4e87ad9f8e498b3b1b720b (patch)
treec66cbd2704e441c5bccc24cee14b6d2ea18cfb4b /meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
parent4faa63047662bfd11814da81b4fc3f75814ad305 (diff)
downloadpoky-528835ba233341af2c4e87ad9f8e498b3b1b720b.tar.gz
linux-yocto/4.4: drop recipe
As was previously announced, anything older than 4.14 is being dropped in the master/release branches to better support newer processors and to ensure that safe/secure kernels are the defaults for all builds. The time required to update the older kernels with constant updates (more than just CVEs) is not justified in new releases. (From OE-Core rev: 79d679b2f4a1c540f6c8b8fd3f268aa5c2634d57) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb36
1 files changed, 0 insertions, 36 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
deleted file mode 100644
index 5fd13f13c9..0000000000
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.4.bb
+++ /dev/null
@@ -1,36 +0,0 @@
1KBRANCH ?= "standard/preempt-rt/base"
2
3require recipes-kernel/linux/linux-yocto.inc
4
5# Skip processing of this recipe if it is not explicitly specified as the
6# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
7# to build multiple virtual/kernel providers, e.g. as dependency of
8# core-image-rt-sdk, core-image-rt.
9python () {
10 if d.getVar("KERNEL_PACKAGE_NAME") == "kernel" and d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-yocto-rt":
11 raise bb.parse.SkipRecipe("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
12}
13
14SRCREV_machine ?= "d5efeeeb928a0111fc187fd1e8d03d2e4e35d4a0"
15SRCREV_meta ?= "b149d14ccae8349ab33e101f6af233a12f4b17ba"
16
17SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.4.git;branch=${KBRANCH};name=machine \
18 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.4;destsuffix=${KMETA}"
19
20LINUX_VERSION ?= "4.4.113"
21
22PV = "${LINUX_VERSION}+git${SRCPV}"
23
24KMETA = "kernel-meta"
25KCONF_BSP_AUDIT_LEVEL = "2"
26
27LINUX_KERNEL_TYPE = "preempt-rt"
28
29COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuarm|qemuppc|qemumips)"
30
31# Functionality flags
32KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/taskstats/taskstats.scc"
33KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
34KERNEL_FEATURES_append_qemuall=" cfg/virtio.scc"
35KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
36KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"