summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-06-06 22:07:28 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-11-07 21:34:09 +0000
commita67ab45c531ef2723990b7c6ad4eae249d67599f (patch)
tree8d226c6c5c297c7b3cfc6629d92f03950c945d8a /meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
parent5e714f0e38ac70bb02682c23f352383c2c086954 (diff)
downloadpoky-a67ab45c531ef2723990b7c6ad4eae249d67599f.tar.gz
linux-yocto/4.12: gcc8 + platform support
Integrating the following changes to fix gcc8 issues, add perf support for new platforms, and misc bug fixes: 7e7ac3f0fda9 perf vendor events intel: Update Goldmont events to V12 0a384f4a74bb perf intel-pt: Always set no branch for dummy event d55c0eebc474 perf intel-pt: Set no_aux_samples for the tracking event 1f0b8b1b621f perf vendor events: Add Goldmont Plus V1 event file 6b230bd7967e objtool, perf: Fix GCC 8 -Wrestrict error 2eb720eab978 tools/lib/subcmd/pager.c: do not alias select() params 16818d5811b1 clocksource/drivers/arm_arch_timer: Fix mem frame loop initialization 0924074f300a of: dynamic: fix memory leak related to properties of __of_node_dup f6579a9e6a8e debugobjects: Make kmemleak ignore debug objects 9184d19fa9ba intel-socfpga: dts: improve qspi node for rsu feature 68846ecd1d27 intel-socfpga: dts: add rsu node to enable rsu driver 9f174f4e95f7 FogBugz #514234: arm64: dts: stratix10: Add PL330 DMA to Stratix10 dts 8a97ef8580e8 FogBugz #554835-3: Intel RSU binding documentation c850e5570554 FogBugz #554835-1: Add Stratix 10 SoC RSU Driver e030a1b198b4 FogBugz #549288-4: dts: add Stratix10 sdram ecc c25a3bffb901 FogBugz #549288-3: edac: Add support for Stratix10 SDRAM EDAC 64430c11c84b FogBugz #549288-2: Add Stratix10 ECC Manager binding c34e0d995e50 FogBugz #549288-1: misc: Stratix10 Protected register access defines ac8afaba8d13 mtd: spi-nor: cadence-quadspi: Fix page fault kernel panic 16431863e036 FogBugz #554812: fpga: stratix10: unitialized data 1ee99e139667 arm64: dts: stratix10: Change pad skew values for EMAC0 PHY driver 3269b14acb76 FogBugz #251539-2: dts: Add Altera Quad SPI Driver Device Tree Binding 99a5d81c3ea7 FogBugz #251539-1: Add Altera Quad SPI Driver (From OE-Core rev: 37410a8ff156530dabdfdc7be4cd575768fa688d) (From OE-Core rev: bffa3ca508b8542157efdd2ff61ff8a7922a6468) (From OE-Core rev: 6130fad4231f4fb78abffb11b397fa6e4261be13) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
index b7c03ee79a..871edf1d3c 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.12.bb
@@ -11,7 +11,7 @@ python () {
11 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it") 11 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
12} 12}
13 13
14SRCREV_machine ?= "705d03507a0c10dcbf9cad3ff70f5d60b70f2d99" 14SRCREV_machine ?= "75a9dd36c291ce674ef6d14b74c5096de9f59ca3"
15SRCREV_meta ?= "46171de19220c49d670544017cfbeffc1ec70e80" 15SRCREV_meta ?= "46171de19220c49d670544017cfbeffc1ec70e80"
16 16
17SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;branch=${KBRANCH};name=machine \ 17SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.12.git;branch=${KBRANCH};name=machine \