summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2017-08-20 22:58:18 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-23 12:06:51 +0100
commit50265b486e2c37a080f1101264bffc5bfd108e79 (patch)
treee490359b6c17f3c984483a5c47cff085a254d314 /meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
parent1a8c7cd0611607c6aac90f574b777dd51ae43f44 (diff)
downloadpoky-50265b486e2c37a080f1101264bffc5bfd108e79.tar.gz
linux-yocto: remove 4.1 recipes
We have 4.4 and 4.9 as LTS kernels, the 4.1 variants are no longer needed and are dropped. (From OE-Core rev: 1a25cea311cbebb2af0c1a0b964208281e6026de) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb36
1 files changed, 0 insertions, 36 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
deleted file mode 100644
index f984f7a93d..0000000000
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.1.bb
+++ /dev/null
@@ -1,36 +0,0 @@
1KBRANCH ?= "standard/preempt-rt/base"
2
3require recipes-kernel/linux/linux-yocto.inc
4
5# Skip processing of this recipe if it is not explicitly specified as the
6# PREFERRED_PROVIDER for virtual/kernel. This avoids errors when trying
7# to build multiple virtual/kernel providers, e.g. as dependency of
8# core-image-rt-sdk, core-image-rt.
9python () {
10 if d.getVar("PREFERRED_PROVIDER_virtual/kernel") != "linux-yocto-rt":
11 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-rt to enable it")
12}
13
14SRCREV_machine ?= "091d8c17b1ba75344ed88a909ead563139de68b3"
15SRCREV_meta ?= "660468df599bbd79a287a8a703d9ca066fd6a074"
16
17SRC_URI = "git://git.yoctoproject.org/linux-yocto-4.1.git;branch=${KBRANCH};name=machine \
18 git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.1;destsuffix=${KMETA}"
19
20LINUX_VERSION ?= "4.1.42"
21
22PV = "${LINUX_VERSION}+git${SRCPV}"
23
24KMETA = "kernel-meta"
25KCONF_BSP_AUDIT_LEVEL = "2"
26
27LINUX_KERNEL_TYPE = "preempt-rt"
28
29COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuarm|qemuppc|qemumips)"
30
31# Functionality flags
32KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/taskstats/taskstats.scc"
33KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
34KERNEL_FEATURES_append_qemuall=" cfg/virtio.scc"
35KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
36KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"