summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2012-06-07 15:59:46 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-08 11:56:31 +0100
commit9cf85014444a55ecfd2bd794ff267f68fa216928 (patch)
tree7c8186364190f9c2fb4d10081968bf79a3747576 /meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
parentb0789103afd51fb74b8dd47e0b5584f65c96b90c (diff)
downloadpoky-9cf85014444a55ecfd2bd794ff267f68fa216928.tar.gz
linux-yocto: add machine aliases for yocto BSPs
To avoid mapping machine names to kernel machine names in recipes, we can define multiple KMACHINE names for a single in tree board. This allows the tools to match a board description to multiple different MACHINEs. As a result, we can remove the explicit KMACHINE mappings from the linux-yocto recipes and allow the KMACHINE=${MACHINE} default to handle mappings. Individual recipes an bbappends can override this as required. (From OE-Core rev: d3dc05a4b808136876cb257a568737abfaceeadd) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb9
1 files changed, 1 insertions, 8 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
index 929aa8503a..508beb1768 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
@@ -1,13 +1,6 @@
1inherit kernel 1inherit kernel
2require recipes-kernel/linux/linux-yocto.inc 2require recipes-kernel/linux/linux-yocto.inc
3 3
4KMACHINE = "common-pc"
5KMACHINE_qemux86 = "common-pc"
6KMACHINE_qemux86-64 = "common-pc-64"
7KMACHINE_qemuarm = "arm-versatile-926ejs"
8KMACHINE_qemuppc = "qemu-ppc32"
9KMACHINE_qemumips = "mti-malta32-be"
10
11KBRANCH = "yocto/standard/preempt-rt/base" 4KBRANCH = "yocto/standard/preempt-rt/base"
12KBRANCH_qemuppc = "yocto/standard/preempt-rt/qemu-ppc32" 5KBRANCH_qemuppc = "yocto/standard/preempt-rt/qemu-ppc32"
13 6
@@ -17,7 +10,7 @@ KMETA = "meta"
17 10
18SRCREV_machine ?= "e67428d9966eecec4c081993dc64ceb5c0e64643" 11SRCREV_machine ?= "e67428d9966eecec4c081993dc64ceb5c0e64643"
19SRCREV_machine_qemuppc ?= "dcca458cb92cc287f70e4062f02460f36a881b16" 12SRCREV_machine_qemuppc ?= "dcca458cb92cc287f70e4062f02460f36a881b16"
20SRCREV_meta ?= "34e0d2b4b4e9778b31f9ea99ca43f0dc71a7ee23" 13SRCREV_meta ?= "b040132c19d70b00fc49f3b7e08c2ed52ac59f92"
21 14
22PR = "r2" 15PR = "r2"
23PV = "${LINUX_VERSION}+git${SRCPV}" 16PV = "${LINUX_VERSION}+git${SRCPV}"