summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2011-08-24 16:50:26 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-24 15:27:33 -0700
commit2c8120d4895c1e2539df2226bae5b5f3b914cb07 (patch)
tree4d31a54f0d60c97dd227f95b3c50f058e7bd1c90 /meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
parentd7b152da6502366c13af7ab773d55673f70eac4c (diff)
downloadpoky-2c8120d4895c1e2539df2226bae5b5f3b914cb07.tar.gz
linux-yocto-rt: update qemuppc support and streamline variables
Fixes [YOCTO #1391] Fixes [YOCTO #1389] qemuppc must have a dedicated branch for -rt support, since it has board specific patches that are not suitable for a common location. This fixes the boot by propagating some common fixes and by syncing to the latest meta-configuration. There are some variables that are now in linux-yocto.inc and need not be defined by the kernel recipe itself, so we can safely remove them with no impact on the build. CC: Darren Hart <dvhart@linux.intel.com> (From OE-Core rev: fc0220b59a15f8cff57c13fe7966d05f7386da71) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb11
1 files changed, 4 insertions, 7 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
index c8a175dad8..61210debf1 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
@@ -9,14 +9,14 @@ KMACHINE_qemuppc = "qemu-ppc32"
9KMACHINE_qemumips = "mti-malta32-be" 9KMACHINE_qemumips = "mti-malta32-be"
10 10
11KBRANCH = "yocto/standard/preempt-rt/base" 11KBRANCH = "yocto/standard/preempt-rt/base"
12KMETA = meta 12KBRANCH_qemuppc = "yocto/standard/preempt-rt/qemu-ppc32"
13 13
14LINUX_VERSION ?= "3.0" 14LINUX_VERSION ?= "3.0"
15LINUX_KERNEL_TYPE = "preempt-rt" 15LINUX_KERNEL_TYPE = "preempt-rt"
16LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE}"
17 16
18SRCREV_machine = "7e1e5b6c8a13c615feb0d7b6d37988a094aae98f" 17SRCREV_machine ?= "67ce0924042a2faa12b71ac3e92175c789c32af6"
19SRCREV_meta = "7782fc673afd6a1c742409896ae787560d96fce8" 18SRCREV_machine_qemuppc ?= "839638f4efda0c70c6f491161ab2c042f5bc3e66"
19SRCREV_meta ?= "13dbce30d6a647228bf5a9483a9b9c2da1514f78"
20 20
21PR = "r0" 21PR = "r0"
22PV = "${LINUX_VERSION}+git${SRCPV}" 22PV = "${LINUX_VERSION}+git${SRCPV}"
@@ -30,14 +30,11 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.0.git;protocol=git;nocheckou
30COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuarm)" 30COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuarm)"
31 31
32# Functionality flags 32# Functionality flags
33KERNEL_REVISION_CHECKING ?= "t"
34KERNEL_FEATURES=features/netfilter 33KERNEL_FEATURES=features/netfilter
35KERNEL_FEATURES_append=" features/taskstats" 34KERNEL_FEATURES_append=" features/taskstats"
36KERNEL_FEATURES_append_qemux86=" cfg/sound" 35KERNEL_FEATURES_append_qemux86=" cfg/sound"
37KERNEL_FEATURES_append_qemux86-64=" cfg/sound" 36KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
38 37
39YOCTO_KERNEL_META_DATA=t
40
41# extra tasks 38# extra tasks
42addtask kernel_link_vmlinux after do_compile before do_install 39addtask kernel_link_vmlinux after do_compile before do_install
43addtask validate_branches before do_patch after do_kernel_checkout 40addtask validate_branches before do_patch after do_kernel_checkout