summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
diff options
context:
space:
mode:
authorDarren Hart <dvhart@linux.intel.com>2011-07-25 11:10:17 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-08-12 17:21:57 +0100
commit15c2a7035dbe5b60bf1ef73b6b7ef64ae8cc9471 (patch)
tree6c11b0eac733dbb884fe7587b64dbc069788176d /meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
parentd9bf0a05c2b6676b5d4a4de5c3ccdbb70a25be17 (diff)
downloadpoky-15c2a7035dbe5b60bf1ef73b6b7ef64ae8cc9471.tar.gz
Move meta-rt recipes to oe-core (meta)
Keeping the rt recipes in their own layer has led to maintenance issues, particularly with the linux-yocto-rt recipes. As these kernel types are part of the same linux-yocto source repository, it seems reasonable to include the rt kernel recipes alongside the standard recipes. A new recipes-rt directory for the other recipes provides adequate separation and eliminates the need for a separate layer. As there is no meta-rt/conf/layer.conf to force the kernel, users must now specify the rt kernel in their local.conf or in the machine.conf: PREFERRED_PROVIDER_virtual/kernel = "linux-yocto-rt" The merging of the rt recipes into the core also eliminates complications with multiple layer dependencies for new BSP layers. Having to either separate RT BSPs from standard BSPs or force users to add meta-rt to bblayers even when not building an RT BSP (because the RT BSPs in the same layer would fail to parse without it) was sub-optimal at best. (From OE-Core rev: bafaaad264fe3e745c714951ddcf2784d33b755a) Signed-off-by: Darren Hart <dvhart@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb b/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
new file mode 100644
index 0000000000..c8a175dad8
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_3.0.bb
@@ -0,0 +1,46 @@
1inherit kernel
2require recipes-kernel/linux/linux-yocto.inc
3
4KMACHINE = "common-pc"
5KMACHINE_qemux86 = "common-pc"
6KMACHINE_qemux86-64 = "common-pc-64"
7KMACHINE_qemuarm = "arm-versatile-926ejs"
8KMACHINE_qemuppc = "qemu-ppc32"
9KMACHINE_qemumips = "mti-malta32-be"
10
11KBRANCH = "yocto/standard/preempt-rt/base"
12KMETA = meta
13
14LINUX_VERSION ?= "3.0"
15LINUX_KERNEL_TYPE = "preempt-rt"
16LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE}"
17
18SRCREV_machine = "7e1e5b6c8a13c615feb0d7b6d37988a094aae98f"
19SRCREV_meta = "7782fc673afd6a1c742409896ae787560d96fce8"
20
21PR = "r0"
22PV = "${LINUX_VERSION}+git${SRCPV}"
23SRCREV_FORMAT = "meta_machine"
24
25SRC_URI = "git://git.yoctoproject.org/linux-yocto-3.0.git;protocol=git;nocheckout=1;branch=${KBRANCH},meta;name=machine,meta"
26
27# Omit broken machines from COMPATIBLE_MACHINE
28# qemuppc hangs at boot
29# qemumips panics at boot
30COMPATIBLE_MACHINE = "(qemux86|qemux86-64|qemuarm)"
31
32# Functionality flags
33KERNEL_REVISION_CHECKING ?= "t"
34KERNEL_FEATURES=features/netfilter
35KERNEL_FEATURES_append=" features/taskstats"
36KERNEL_FEATURES_append_qemux86=" cfg/sound"
37KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
38
39YOCTO_KERNEL_META_DATA=t
40
41# extra tasks
42addtask kernel_link_vmlinux after do_compile before do_install
43addtask validate_branches before do_patch after do_kernel_checkout
44addtask kernel_configcheck after do_configure before do_compile
45
46require recipes-kernel/linux/linux-tools.inc