summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-dev.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2013-12-05 14:31:55 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-14 09:11:15 +0000
commit4bb18c41e8537531bd8f8749f320fa6ddc35e398 (patch)
tree98104ed3cea3a6310671004a3a482998fb4a0a62 /meta/recipes-kernel/linux/linux-yocto-dev.bb
parentdb4961ba7fde74e408b031b1464064398a7fd0e4 (diff)
downloadpoky-4bb18c41e8537531bd8f8749f320fa6ddc35e398.tar.gz
linux-yocto-dev: allow static SRCREVs via include
The linux-yocto dev recipe is intended to track the latest revisions of the kernel tree by default. To control revision churn, and integrate into a regular build schedule having the ability to specify a set of SRCREVs without modifying the recipe itself is desired. So we introduce an optional include file, and variables that control whether or not the static SRCREVs are used: USE_MACHINE_AUTOREV and USE_META_AUTOREV, to add this flexibility. (From OE-Core rev: 5877781d1dcb2883d00097b66ff2481a4a5ff930) Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-dev.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-dev.bb25
1 files changed, 18 insertions, 7 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-dev.bb b/meta/recipes-kernel/linux/linux-yocto-dev.bb
index e7b8d8b2a7..e8d14b966d 100644
--- a/meta/recipes-kernel/linux/linux-yocto-dev.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-dev.bb
@@ -11,6 +11,12 @@
11inherit kernel 11inherit kernel
12require recipes-kernel/linux/linux-yocto.inc 12require recipes-kernel/linux/linux-yocto.inc
13 13
14USE_MACHINE_AUTOREV ?= "1"
15USE_META_AUTOREV ?= "1"
16
17# provide this .inc to set specific revisions
18include recipes-kernel/linux/linux-yocto-dev-revisions.inc
19
14KBRANCH = "standard/base" 20KBRANCH = "standard/base"
15KBRANCH_DEFAULT = "${KBRANCH}" 21KBRANCH_DEFAULT = "${KBRANCH}"
16KMETA = "meta" 22KMETA = "meta"
@@ -22,15 +28,19 @@ SRC_URI = "git://git.pokylinux.org/linux-yocto-dev.git;nocheckout=1;branch=${KBR
22# linux-yocto-dev is the preferred provider, they will be overridden to 28# linux-yocto-dev is the preferred provider, they will be overridden to
23# AUTOREV in following anonymous python routine and resolved when the 29# AUTOREV in following anonymous python routine and resolved when the
24# variables are finalized. 30# variables are finalized.
25SRCREV_machine="29594404d7fe73cd80eaa4ee8c43dcc53970c60e" 31SRCREV_machine ?= "29594404d7fe73cd80eaa4ee8c43dcc53970c60e"
26SRCREV_meta="29594404d7fe73cd80eaa4ee8c43dcc53970c60e" 32SRCREV_meta ?= "29594404d7fe73cd80eaa4ee8c43dcc53970c60e"
27 33
28python () { 34python () {
29 if d.getVar("PREFERRED_PROVIDER_virtual/kernel", True) != "linux-yocto-dev": 35 if d.getVar("PREFERRED_PROVIDER_virtual/kernel", True) != "linux-yocto-dev":
30 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-dev to enable it") 36 raise bb.parse.SkipPackage("Set PREFERRED_PROVIDER_virtual/kernel to linux-yocto-dev to enable it")
31 else: 37 else:
32 d.setVar("SRCREV_machine", "${AUTOREV}") 38 # if the revisions have been changed from the defaults above we leave them
33 d.setVar("SRCREV_meta", "${AUTOREV}") 39 # alone. But if the defaults are left, we change to AUTOREV.
40 if d.getVar("USE_MACHINE_AUTOREV", True) == "1":
41 d.setVar("SRCREV_machine", "${AUTOREV}")
42 if d.getVar("USE_META_AUTOREV", True) == "1":
43 d.setVar("SRCREV_meta", "${AUTOREV}")
34} 44}
35 45
36LINUX_VERSION ?= "3.10+" 46LINUX_VERSION ?= "3.10+"
@@ -40,8 +50,9 @@ PV = "${LINUX_VERSION}+git${SRCPV}"
40COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemumips64|qemux86-64)" 50COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemumips64|qemux86-64)"
41 51
42# Functionality flags 52# Functionality flags
43KERNEL_FEATURES_append = " features/netfilter/netfilter.scc" 53KERNEL_EXTRA_FEATURES ?= "features/netfilter/netfilter.scc features/taskstats/taskstats.scc"
44KERNEL_FEATURES_append_qemux86=" cfg/sound.scc" 54KERNEL_FEATURES_append = " ${KERNEL_EXTRA_FEATURES}"
55KERNEL_FEATURES_append_qemux86=" cfg/sound.scc cfg/paravirt_kvm.scc"
45KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc" 56KERNEL_FEATURES_append_qemux86-64=" cfg/sound.scc"
46KERNEL_FEATURES_append_qemux86=" cfg/paravirt_kvm.scc"
47KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}" 57KERNEL_FEATURES_append = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", " cfg/x32.scc", "" ,d)}"
58