summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kmod/kmod-native_git.bb
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2021-12-20 18:26:34 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-12-21 12:01:41 +0000
commitc6afe999228b642fe15fe031d7fbb2544e284db4 (patch)
tree3f897c8c0bc37c8ceaac03904b0a6701b7ae0e74 /meta/recipes-kernel/kmod/kmod-native_git.bb
parent70341cdbd8d271b5f16d25e3cd95ce1e74b0f962 (diff)
downloadpoky-c6afe999228b642fe15fe031d7fbb2544e284db4.tar.gz
kmod: merge target/native recipes
There's no good reason to keep separate target and native recipes for kmod, so merge them into a single kmod_29.bb which uses class extension. The symlinks are not created differently for target vs native builds, as the native sbindir is in PATH. (From OE-Core rev: 9abbf481438fba10a7512fb1ad1bff5d48e6fbdc) Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/kmod/kmod-native_git.bb')
-rw-r--r--meta/recipes-kernel/kmod/kmod-native_git.bb15
1 files changed, 0 insertions, 15 deletions
diff --git a/meta/recipes-kernel/kmod/kmod-native_git.bb b/meta/recipes-kernel/kmod/kmod-native_git.bb
deleted file mode 100644
index 4dd34b1c82..0000000000
--- a/meta/recipes-kernel/kmod/kmod-native_git.bb
+++ /dev/null
@@ -1,15 +0,0 @@
1# Copyright (C) 2012 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4require kmod.inc
5
6DEPENDS += "zlib-native"
7
8inherit native
9
10do_install:append (){
11 for tool in depmod insmod lsmod modinfo modprobe rmmod
12 do
13 ln -s kmod ${D}${bindir}/$tool
14 done
15}