summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kexec/kexec-tools_2.0.16.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-05-18 19:13:48 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-29 21:07:14 +0100
commit6dbac6e225bb8579c6098981ed57de6001cd4d14 (patch)
treea9389bbf391ddc61689f8bcbdfcad71aea20a464 /meta/recipes-kernel/kexec/kexec-tools_2.0.16.bb
parent1f9bb6c96a24062be7e9d01abbd391f68a3cc39e (diff)
downloadpoky-6dbac6e225bb8579c6098981ed57de6001cd4d14.tar.gz
kexec-tools: upgrade 2.0.16 -> 2.0.17
(From OE-Core rev: 8da23d49367f48a195b952b5c2e2f7ce2221a572) Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/kexec/kexec-tools_2.0.16.bb')
-rw-r--r--meta/recipes-kernel/kexec/kexec-tools_2.0.16.bb87
1 files changed, 0 insertions, 87 deletions
diff --git a/meta/recipes-kernel/kexec/kexec-tools_2.0.16.bb b/meta/recipes-kernel/kexec/kexec-tools_2.0.16.bb
deleted file mode 100644
index bd87b371c2..0000000000
--- a/meta/recipes-kernel/kexec/kexec-tools_2.0.16.bb
+++ /dev/null
@@ -1,87 +0,0 @@
1
2SUMMARY = "Kexec fast reboot tools"
3DESCRIPTION = "Kexec is a fast reboot feature that lets you reboot to a new Linux kernel"
4AUTHOR = "Eric Biederman"
5HOMEPAGE = "http://kernel.org/pub/linux/utils/kernel/kexec/"
6SECTION = "kernel/userland"
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=ea5bed2f60d357618ca161ad539f7c0a \
9 file://kexec/kexec.c;beginline=1;endline=20;md5=af10f6ae4a8715965e648aa687ad3e09"
10DEPENDS = "zlib xz"
11
12PR = "r1"
13
14SRC_URI = "${KERNELORG_MIRROR}/linux/utils/kernel/kexec/kexec-tools-${PV}.tar.gz \
15 file://kdump \
16 file://kdump.conf \
17 file://kdump.service \
18 file://0002-powerpc-change-the-memory-size-limit.patch \
19 file://0001-purgatory-Pass-r-directly-to-linker.patch \
20 file://0010-kexec-ARM-Fix-add_buffer_phys_virt-align-issue.patch \
21 file://kexec-x32.patch \
22 file://0001-Disable-PIE-during-link.patch \
23 file://0001-arm64-Set-fno-PIC-along-with-mcmodel-large.patch \
24 "
25
26SRC_URI[md5sum] = "5198968de79b5ded96f97f3c2ea9637b"
27SRC_URI[sha256sum] = "cf17fc99bf77c9b39f06ee88ac0e86d0349c4a0c3f8214a3cc78eece872f6f3a"
28
29inherit autotools update-rc.d systemd
30
31export LDFLAGS = "-L${STAGING_LIBDIR}"
32EXTRA_OECONF = " --with-zlib=yes"
33
34do_compile_prepend() {
35 # Remove the prepackaged config.h from the source tree as it overrides
36 # the same file generated by configure and placed in the build tree
37 rm -f ${S}/include/config.h
38
39 # Remove the '*.d' file to make sure the recompile is OK
40 for dep in `find ${B} -type f -name '*.d'`; do
41 dep_no_d="`echo $dep | sed 's#.d$##'`"
42 # Remove file.d when there is a file.o
43 if [ -f "$dep_no_d.o" ]; then
44 rm -f $dep
45 fi
46 done
47}
48
49do_install_append () {
50 install -d ${D}${sysconfdir}/sysconfig
51 install -m 0644 ${WORKDIR}/kdump.conf ${D}${sysconfdir}/sysconfig
52
53 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
54 install -D -m 0755 ${WORKDIR}/kdump ${D}${sysconfdir}/init.d/kdump
55 fi
56
57 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
58 install -D -m 0755 ${WORKDIR}/kdump ${D}${libexecdir}/kdump-helper
59 install -D -m 0644 ${WORKDIR}/kdump.service ${D}${systemd_unitdir}/system/kdump.service
60 sed -i -e 's,@LIBEXECDIR@,${libexecdir},g' ${D}${systemd_unitdir}/system/kdump.service
61 fi
62}
63
64PACKAGES =+ "kexec kdump vmcore-dmesg"
65
66ALLOW_EMPTY_${PN} = "1"
67RRECOMMENDS_${PN} = "kexec kdump vmcore-dmesg"
68
69FILES_kexec = "${sbindir}/kexec"
70FILES_kdump = "${sbindir}/kdump \
71 ${sysconfdir}/sysconfig/kdump.conf \
72 ${sysconfdir}/init.d/kdump \
73 ${libexecdir}/kdump-helper \
74 ${systemd_unitdir}/system/kdump.service \
75"
76
77FILES_vmcore-dmesg = "${sbindir}/vmcore-dmesg"
78
79INITSCRIPT_PACKAGES = "kdump"
80INITSCRIPT_NAME_kdump = "kdump"
81INITSCRIPT_PARAMS_kdump = "start 56 2 3 4 5 . stop 56 0 1 6 ."
82
83SECURITY_PIE_CFLAGS_remove = "-fPIE -pie"
84
85COMPATIBLE_HOST = '(x86_64.*|i.86.*|arm.*|aarch64.*|powerpc.*|mips.*)-(linux|freebsd.*)'
86
87INSANE_SKIP_${PN} = "arch"