summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/cryptodev/cryptodev-tests_1.8.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-12-16 16:02:45 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-28 09:25:14 +0000
commitedde9afcf9b5e581af8f4f455fc39ff9eb30c672 (patch)
treed929c9af30f744503a895936909ae979f35083d1 /meta/recipes-kernel/cryptodev/cryptodev-tests_1.8.bb
parent9da93087810a991b356f0d84ae9edd8919f22fda (diff)
downloadpoky-edde9afcf9b5e581af8f4f455fc39ff9eb30c672.tar.gz
cryptodev: update to 1.8
Drop 0001-ioctl.c-Fix-build-on-3.19.patch and 0002-Fix-tests-Makefile-usage-of-LDLIBS-vs.-LDFLAGS.patch, the code has been fixed upstream. (From OE-Core rev: 762b3111f3124ee75404835da751fb95b8466fd4) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/cryptodev/cryptodev-tests_1.8.bb')
-rw-r--r--meta/recipes-kernel/cryptodev/cryptodev-tests_1.8.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-kernel/cryptodev/cryptodev-tests_1.8.bb b/meta/recipes-kernel/cryptodev/cryptodev-tests_1.8.bb
new file mode 100644
index 0000000000..c4005242a7
--- /dev/null
+++ b/meta/recipes-kernel/cryptodev/cryptodev-tests_1.8.bb
@@ -0,0 +1,21 @@
1require cryptodev.inc
2
3SUMMARY = "A test suite for /dev/crypto device driver"
4
5DEPENDS += "openssl"
6
7SRC_URI += " \
8file://0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch \
9"
10
11EXTRA_OEMAKE='KERNEL_DIR="${STAGING_EXECPREFIXDIR}" PREFIX="${D}"'
12
13do_compile() {
14 oe_runmake testprogs
15}
16
17do_install() {
18 oe_runmake install_tests
19}
20
21FILES_${PN} = "${bindir}/tests_cryptodev/*"