summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/cryptodev/cryptodev-tests_1.13.bb
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2023-05-01 12:34:12 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-05-05 11:07:26 +0100
commit2cd57b3f33803fb5f0bf12044941a2e1cc038b48 (patch)
treedf67019e0029fcc3f66e94d484e1632a3992821d /meta/recipes-kernel/cryptodev/cryptodev-tests_1.13.bb
parentb729a12fc0409e6301c40f88a54c793396725709 (diff)
downloadpoky-2cd57b3f33803fb5f0bf12044941a2e1cc038b48.tar.gz
cryptodev: upgrade to 1.13
Upgrade cryptodev to new release 1.13. This resoves the Kernel build issues for 6.3.y, where Crypto API has been updated, see [1]. Refresh all layer patches with `devtool` to resolve hunks. Link: [1]: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=255e48eb17684157336bd6dd98d22c1b2d9e3f43 (From OE-Core rev: dc85b747af14f5262590e72e55d2c49670cf09a7) Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/cryptodev/cryptodev-tests_1.13.bb')
-rw-r--r--meta/recipes-kernel/cryptodev/cryptodev-tests_1.13.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-kernel/cryptodev/cryptodev-tests_1.13.bb b/meta/recipes-kernel/cryptodev/cryptodev-tests_1.13.bb
new file mode 100644
index 0000000000..c541478796
--- /dev/null
+++ b/meta/recipes-kernel/cryptodev/cryptodev-tests_1.13.bb
@@ -0,0 +1,22 @@
1require cryptodev.inc
2
3SUMMARY = "A test suite for /dev/crypto device driver"
4
5DEPENDS += "openssl"
6
7SRC_URI += " \
8file://0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch \
9file://0001-tests-Makefile-do-not-use-Werror.patch \
10"
11
12EXTRA_OEMAKE='KERNEL_DIR="${STAGING_EXECPREFIXDIR}" PREFIX="${D}"'
13
14do_compile() {
15 oe_runmake testprogs
16}
17
18do_install() {
19 oe_runmake install_tests
20}
21
22FILES:${PN} = "${bindir}/*"