summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xwayland/xwayland_23.2.5.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-08 13:58:48 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-08 23:33:32 +0100
commitf68203810d77bfe31c08d54b317e7ad7512f8d8c (patch)
treeb0889a366e91c21c83131de64f756578673b367f /meta/recipes-graphics/xwayland/xwayland_23.2.5.bb
parent2426053c2c74bd3621220b7a9000915958306cfe (diff)
downloadpoky-f68203810d77bfe31c08d54b317e7ad7512f8d8c.tar.gz
xwayland: Upgrade 23.2.4 -> 23.2.5
""" This release contains the 3 security fixes that actually apply to Xwayland reported in today's security advisory: * CVE-2024-31080 * CVE-2024-31081 * CVE-2024-31083 Additionally, it also contains a couple of other fixes, a copy/paste error in the DeviceStateNotify event and a fix to enable buttons with pointer gestures for backward compatibility with legacy X11 clients. """ https://lists.x.org/archives/xorg/2024-April/061614.html (From OE-Core rev: c89fea4ffb101e3d7079e126721b95fdf199b4aa) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xwayland/xwayland_23.2.5.bb')
-rw-r--r--meta/recipes-graphics/xwayland/xwayland_23.2.5.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xwayland/xwayland_23.2.5.bb b/meta/recipes-graphics/xwayland/xwayland_23.2.5.bb
new file mode 100644
index 0000000000..b934a873d1
--- /dev/null
+++ b/meta/recipes-graphics/xwayland/xwayland_23.2.5.bb
@@ -0,0 +1,45 @@
1SUMMARY = "XWayland is an X Server that runs under Wayland."
2DESCRIPTION = "XWayland is an X Server running as a Wayland client, \
3and thus is capable of displaying native X11 client applications in a \
4Wayland compositor environment. The goal of XWayland is to facilitate \
5the transition from X Window System to Wayland environments, providing \
6a way to run unported applications in the meantime."
7HOMEPAGE = "https://fedoraproject.org/wiki/Changes/XwaylandStandalone"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=5df87950af51ac2c5822094553ea1880"
11
12SRC_URI = "https://www.x.org/archive/individual/xserver/xwayland-${PV}.tar.xz"
13SRC_URI[sha256sum] = "33ec7ff2687a59faaa52b9b09aa8caf118e7ecb6aed8953f526a625ff9f4bd90"
14
15UPSTREAM_CHECK_REGEX = "xwayland-(?P<pver>\d+(\.(?!90\d)\d+)+)\.tar"
16
17inherit meson features_check pkgconfig
18REQUIRED_DISTRO_FEATURES = "x11 opengl"
19
20DEPENDS += "xorgproto xtrans pixman libxkbfile libxfont2 wayland wayland-native wayland-protocols libdrm libepoxy libxcvt"
21
22OPENGL_PKGCONFIGS = "glx glamor dri3"
23PACKAGECONFIG ??= "${XORG_CRYPTO} \
24 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '${OPENGL_PKGCONFIGS}', '', d)} \
25"
26PACKAGECONFIG[dri3] = "-Ddri3=true,-Ddri3=false,libxshmfence"
27PACKAGECONFIG[glx] = "-Dglx=true,-Dglx=false,virtual/libgl virtual/libx11"
28PACKAGECONFIG[glamor] = "-Dglamor=true,-Dglamor=false,libepoxy virtual/libgbm,libegl"
29PACKAGECONFIG[unwind] = "-Dlibunwind=true,-Dlibunwind=false,libunwind"
30PACKAGECONFIG[xinerama] = "-Dxinerama=true,-Dxinerama=false"
31
32# Xorg requires a SHA1 implementation, pick one
33XORG_CRYPTO ??= "openssl"
34PACKAGECONFIG[openssl] = "-Dsha1=libcrypto,,openssl"
35PACKAGECONFIG[nettle] = "-Dsha1=libnettle,,nettle"
36PACKAGECONFIG[gcrypt] = "-Dsha1=libgcrypt,,libgcrypt"
37
38do_install:append() {
39 # remove files not needed and clashing with xserver-xorg
40 rm -rf ${D}/${libdir}/xorg/
41}
42
43FILES:${PN} += "${libdir}/xorg/protocol.txt"
44
45RDEPENDS:${PN} += "xkbcomp"