summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.31.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-11-02 17:48:32 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-11-03 08:21:11 +0000
commitc35646464b469fbe14a0a1bca6341f0e4f59adfa (patch)
treef238fec56496d21f854971464ab17ab41137d4aa /meta/recipes-graphics/xorg-lib/xkeyboard-config_2.31.bb
parent5915e2051391d12b434dd57365db43dde716de08 (diff)
downloadpoky-c35646464b469fbe14a0a1bca6341f0e4f59adfa.tar.gz
xkeyboard-config: upgrade 2.30 -> 2.31
Add python3native, as at least python 3.6 is needed during build, and not all hosts have that. (From OE-Core rev: a53586bd5230f66be8a44428d1a29235cf4ca2a7) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/xkeyboard-config_2.31.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/xkeyboard-config_2.31.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.31.bb b/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.31.bb
new file mode 100644
index 0000000000..ad150544e1
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/xkeyboard-config_2.31.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Keyboard configuration database for X Window"
2
3DESCRIPTION = "The non-arch keyboard configuration database for X \
4Window. The goal is to provide the consistent, well-structured, \
5frequently released open source of X keyboard configuration data for X \
6Window System implementations. The project is targeted to XKB-based \
7systems."
8
9HOMEPAGE = "http://freedesktop.org/wiki/Software/XKeyboardConfig"
10BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-config"
11
12LICENSE = "MIT & MIT-style"
13LIC_FILES_CHKSUM = "file://COPYING;md5=0e7f21ca7db975c63467d2e7624a12f9"
14
15SRC_URI = "${XORG_MIRROR}/individual/data/xkeyboard-config/${BPN}-${PV}.tar.bz2"
16SRC_URI[sha256sum] = "da44181f2c8828789c720decf7d13acb3c3950e2a040af5132f50f04bb6aada3"
17
18SECTION = "x11/libs"
19DEPENDS = "util-macros libxslt-native"
20
21EXTRA_OECONF = "--with-xkb-rules-symlink=xorg --disable-runtime-deps"
22
23FILES_${PN} += "${datadir}/X11/xkb"
24
25inherit autotools pkgconfig gettext python3native
26
27do_install_append () {
28 install -d ${D}${datadir}/X11/xkb/compiled
29 cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg
30}