summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/libxt_1.1.1.bb
diff options
context:
space:
mode:
authorDexuan Cui <dexuan.cui@intel.com>2011-04-12 00:58:46 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-04-18 05:49:29 +0100
commitfc1c2096d1e95c6d69f7ec1c426a6a3bc424fe01 (patch)
tree6ebe113c22e9093127254407acda19206ac28750 /meta/recipes-graphics/xorg-lib/libxt_1.1.1.bb
parent7fafbe235da6dd8960ec2fef9455494bb36433c6 (diff)
downloadpoky-fc1c2096d1e95c6d69f7ec1c426a6a3bc424fe01.tar.gz
libxt: update from 1.0.9 to the latest version 1.1.1
Update LIC_FILES_CHKSUM due to the only change to COPYING. -Copyright (c) 1993, Oracle and/or its affiliates. All rights reserved. +Copyright (c) 1993, 2011, Oracle and/or its affiliates. All rights reserved. (From OE-Core rev: c09196bcd66fb489afdb17265de6a68737f47b71) Signed-off-by: Dexuan Cui <dexuan.cui@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/libxt_1.1.1.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/libxt_1.1.1.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libxt_1.1.1.bb b/meta/recipes-graphics/xorg-lib/libxt_1.1.1.bb
new file mode 100644
index 0000000000..f06739f4b7
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libxt_1.1.1.bb
@@ -0,0 +1,43 @@
1SUMMARY = "Xt: X Toolkit Intrinsics library"
2
3DESCRIPTION = "The Intrinsics are a programming library tailored to the \
4special requirements of user interface construction within a network \
5window system, specifically the X Window System. The Intrinsics and a \
6widget set make up an X Toolkit. The Intrinsics provide the base \
7mechanism necessary to build a wide variety of interoperating widget \
8sets and application environments. The Intrinsics are a layer on top of \
9Xlib, the C Library X Interface. They extend the fundamental \
10abstractions provided by the X Window System while still remaining \
11independent of any particular user interface policy or style."
12
13require xorg-lib-common.inc
14
15LICENSE = "MIT & MIT-style"
16LIC_FILES_CHKSUM = "file://COPYING;md5=3239170e81427c5948287df07691f03f"
17
18
19DEPENDS += "libsm virtual/libx11 kbproto libxdmcp"
20PROVIDES = "xt"
21
22PR = "r0"
23PE = "1"
24
25XORG_PN = "libXt"
26
27BBCLASSEXTEND = "native"
28
29EXTRA_OECONF += "--disable-install-makestrs --disable-xkb"
30
31do_compile() {
32 (
33 unset CC LD CXX CCLD CFLAGS
34 oe_runmake -C util 'XT_CFLAGS=' 'CC=${BUILD_CC}' 'LD=${BUILD_LD}' 'CXX=${BUILD_CXX}' 'CCLD=${BUILD_CCLD}' 'CFLAGS=-D_GNU_SOURCE -I${STAGING_INCDIR_NATIVE} ${BUILD_CFLAGS}' 'LDFLAGS=${BUILD_LDFLAGS}' 'CXXFLAGS=${BUILD_CXXFLAGS}' 'CPPFLAGS=${BUILD_CPPFLAGS}' makestrs
35 )
36 if [ "$?" != "0" ]; then
37 exit 1
38 fi
39 oe_runmake
40}
41
42SRC_URI[md5sum] = "eb22c0a1f172b06b97a3f5ae89768412"
43SRC_URI[sha256sum] = "a2a1c29c684e3c9082cdb920b5aea802b179d19107b9ab2170fda07575559da7"