summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/libxcb_1.16.1.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-03-13 15:08:10 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-16 08:07:01 +0100
commit2d3d3cfb9f04e114a0bd48a3da954bab98386bbc (patch)
tree5bb78450898cd09071ed00e88fa09025e6f74f8b /meta/recipes-graphics/xorg-lib/libxcb_1.16.1.bb
parent30ff5f152f35a6709b1dae5bbc416cd33c458865 (diff)
downloadpoky-2d3d3cfb9f04e114a0bd48a3da954bab98386bbc.tar.gz
libxcb: upgrade 1.16 -> 1.16.1
Changelog: =========== -Enable large file support -Fix compilation on Windows -gitlab CI: use latest xcbproto from git to build against -configure.ac: drop `pthread-stubs` dependency on NetBSD -gitlab CI: regenerate container used for builds (From OE-Core rev: 29cff6301d9c86df1609ac7d1762c38ce527fe4e) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/libxcb_1.16.1.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/libxcb_1.16.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libxcb_1.16.1.bb b/meta/recipes-graphics/xorg-lib/libxcb_1.16.1.bb
new file mode 100644
index 0000000000..de3290aa9f
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libxcb_1.16.1.bb
@@ -0,0 +1,38 @@
1SUMMARY = "XCB: The X protocol C binding library"
2DESCRIPTION = "The X protocol C-language Binding (XCB) is a replacement \
3for Xlib featuring a small footprint, latency hiding, direct access to \
4the protocol, improved threading support, and extensibility."
5HOMEPAGE = "http://xcb.freedesktop.org"
6BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=XCB"
7SECTION = "x11/libs"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7"
11
12SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.xz \
13 file://0001-use-_Alignof-to-avoid-UB-in-ALIGNOF.patch"
14
15SRC_URI[sha256sum] = "f24d187154c8e027b358fc7cb6588e35e33e6a92f11c668fe77396a7ae66e311"
16
17BBCLASSEXTEND = "native nativesdk"
18
19DEPENDS = "xcb-proto xorgproto libxau libpthread-stubs libxdmcp"
20
21PACKAGES_DYNAMIC = "^${PN}-.*"
22
23FILES:${PN} = "${libdir}/libxcb.so.*"
24
25inherit autotools pkgconfig features_check
26
27# The libxau and others requires x11 in DISTRO_FEATURES
28REQUIRED_DISTRO_FEATURES = "x11"
29
30export PYTHON = "python3"
31
32do_install:append () {
33 chown root.root ${D}${datadir}/doc/${BPN}/tutorial -R
34}
35
36python populate_packages:prepend () {
37 do_split_packages(d, '${libdir}', r'^libxcb-(.*)\.so\..*$', '${PN}-%s', 'XCB library module for %s', allow_links=True)
38}