summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib/libxcb_1.12.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-05-26 16:59:28 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-30 15:58:14 +0100
commitea9d27ad4a51d3e394c0ef0a2ca731d910b356cc (patch)
tree462cd0190796a57163d212b84c98b110d4ffc28f /meta/recipes-graphics/xorg-lib/libxcb_1.12.bb
parent621a038cc201778b9d33fe8f3237b754a1b7ef09 (diff)
downloadpoky-ea9d27ad4a51d3e394c0ef0a2ca731d910b356cc.tar.gz
libxcb: upgrade to 1.12
(From OE-Core rev: 476d816a49121ba9a3db7720135d3ddaf51e2cc5) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/xorg-lib/libxcb_1.12.bb')
-rw-r--r--meta/recipes-graphics/xorg-lib/libxcb_1.12.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libxcb_1.12.bb b/meta/recipes-graphics/xorg-lib/libxcb_1.12.bb
new file mode 100644
index 0000000000..62b8bab87f
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libxcb_1.12.bb
@@ -0,0 +1,36 @@
1SUMMARY = "XCB: The X protocol C binding library"
2DESCRIPTION = "The X protocol C-language Binding (XCB) is a replacement \
3for Xlib featuring a small footprint, latency hiding, direct access to \
4the protocol, improved threading support, and extensibility."
5HOMEPAGE = "http://xcb.freedesktop.org"
6BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=XCB"
7SECTION = "x11/libs"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=d763b081cb10c223435b01e00dc0aba7"
11
12SRC_URI = "http://xcb.freedesktop.org/dist/libxcb-${PV}.tar.bz2 \
13 file://xcbincludedir.patch \
14 file://disable-check.patch \
15 file://gcc-mips-pr68302-mips-workaround.patch \
16 "
17SRC_URI[md5sum] = "28e552bd78bc1050b6b26ca1db0e5bb6"
18SRC_URI[sha256sum] = "4adfb1b7c67e99bc9c2ccb110b2f175686576d2f792c8a71b9c8b19014057b5b"
19
20BBCLASSEXTEND = "native nativesdk"
21
22DEPENDS = "xcb-proto xproto libxau libpthread-stubs libxdmcp"
23
24PACKAGES_DYNAMIC = "^libxcb-.*"
25
26FILES_${PN} = "${libdir}/libxcb.so.*"
27
28inherit autotools pkgconfig distro_features_check
29
30# The libxau and others requires x11 in DISTRO_FEATURES
31REQUIRED_DISTRO_FEATURES = "x11"
32REQUIRED_DISTRO_FEATURES_class-native = ""
33
34python populate_packages_prepend () {
35 do_split_packages(d, '${libdir}', '^libxcb-(.*)\.so\..*$', 'libxcb-%s', 'XCB library module for %s', allow_links=True)
36}