summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/libinput_1.16.0.bb
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@cn.fujitsu.com>2020-08-07 05:10:52 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-08-08 09:17:48 +0100
commitdf8b8c553e901db9efc9238fffc0b4771579c940 (patch)
tree4078a5dad5ba5cf826cc2b2b627675ff3b92dcc2 /meta/recipes-graphics/wayland/libinput_1.16.0.bb
parentf87f1a7eec58dfa81c3256f00609682aef7f0204 (diff)
downloadpoky-df8b8c553e901db9efc9238fffc0b4771579c940.tar.gz
libinput: Upgrade 1.15.6 -> 1.16.0
(From OE-Core rev: c862f628a5be1d8a95ad2e82672553ef0c1eda49) Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland/libinput_1.16.0.bb')
-rw-r--r--meta/recipes-graphics/wayland/libinput_1.16.0.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/libinput_1.16.0.bb b/meta/recipes-graphics/wayland/libinput_1.16.0.bb
new file mode 100644
index 0000000000..baf5c1d167
--- /dev/null
+++ b/meta/recipes-graphics/wayland/libinput_1.16.0.bb
@@ -0,0 +1,50 @@
1SUMMARY = "Library to handle input devices in Wayland compositors"
2DESCRIPTION = "libinput is a library to handle input devices in Wayland \
3compositors and to provide a generic X.Org input driver. It provides \
4device detection, device handling, input device event processing and \
5abstraction so minimize the amount of custom input code compositors need to \
6provide the common set of functionality that users expect."
7HOMEPAGE = "http://www.freedesktop.org/wiki/Software/libinput/"
8SECTION = "libs"
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://COPYING;md5=1f2ea9ebff3a2c6d458faf58492efb63"
12
13DEPENDS = "libevdev udev mtdev libcheck"
14
15SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BP}.tar.xz \
16 file://run-ptest \
17 file://determinism.patch \
18 "
19SRC_URI[md5sum] = "b518dae7f603040872739216971ee97b"
20SRC_URI[sha256sum] = "83f6d0c94e5e0dd87094ce73f0edb631919617d24a60ee0ab9bd9197411d76e8"
21
22UPSTREAM_CHECK_REGEX = "libinput-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)"
23
24inherit meson pkgconfig lib_package ptest
25
26# Patch out build directory, otherwise it leaks into ptest binary
27do_configure_append() {
28 sed -i -e "s,${WORKDIR},,g" config.h
29 if [ -e "litest-config.h" ]; then
30 sed -i -e "s,${WORKDIR},,g" litest-config.h
31 fi
32}
33
34PACKAGECONFIG ??= ""
35PACKAGECONFIG[libwacom] = "-Dlibwacom=true,-Dlibwacom=false,libwacom"
36PACKAGECONFIG[gui] = "-Ddebug-gui=true,-Ddebug-gui=false,cairo gtk+3"
37
38UDEVDIR = "`pkg-config --variable=udevdir udev`"
39
40EXTRA_OEMESON += "-Dudev-dir=${UDEVDIR} \
41 -Ddocumentation=false \
42 ${@bb.utils.contains('PTEST_ENABLED', '1', '-Dtests=true -Dinstall-tests=true', '-Dtests=false -Dinstall-tests=false', d)} \
43 -Dzshcompletiondir=no"
44
45# package name changed in 1.8.1 upgrade: make sure package upgrades work
46RPROVIDES_${PN} = "libinput"
47RREPLACES_${PN} = "libinput"
48RCONFLICTS_${PN} = "libinput"
49
50FILES_${PN}-ptest += "${libexecdir}/libinput/libinput-test-suite"