summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/waffle/waffle_1.5.2.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-01-22 16:25:20 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-26 22:49:39 +0000
commitdff038aad5594b47c51294514c975e00c71da966 (patch)
tree09232bdb8bb0c02f8858d0ceecf0e2a3a81de3c7 /meta/recipes-graphics/waffle/waffle_1.5.2.bb
parent89bd19f91b81f53679445b8375c8e0647a56cbfc (diff)
downloadpoky-dff038aad5594b47c51294514c975e00c71da966.tar.gz
waffle: update to 1.5.2
(From OE-Core rev: 7d977e4e9aa4986e59ca99342af8c57e7cfb45e1) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/waffle/waffle_1.5.2.bb')
-rw-r--r--meta/recipes-graphics/waffle/waffle_1.5.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-graphics/waffle/waffle_1.5.2.bb b/meta/recipes-graphics/waffle/waffle_1.5.2.bb
new file mode 100644
index 0000000000..f7db1bc955
--- /dev/null
+++ b/meta/recipes-graphics/waffle/waffle_1.5.2.bb
@@ -0,0 +1,37 @@
1SUMMARY = "cross-platform C library to defer selection of GL API and of window system"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4c5154407c2490750dd461c50ad94797 \
4 file://include/waffle/waffle.h;endline=24;md5=61dbf8697f61c78645e75a93c585b1bf"
5
6SRC_URI = "http://waffle-gl.org/files/release/${BPN}-${PV}/${BPN}-${PV}.tar.xz \
7 file://0001-third_party-threads-Use-PTHREAD_MUTEX_RECURSIVE-by-d.patch \
8 "
9SRC_URI[md5sum] = "c669c91bf2f7e13a5d781c3dbb30fd8c"
10SRC_URI[sha256sum] = "d2c096cf654bf0061323a4b9231a1ef5b749a1e5c7c5bfe067e964219c2a851c"
11
12UPSTREAM_CHECK_URI = "http://www.waffle-gl.org/releases.html"
13
14inherit cmake distro_features_check lib_package
15
16# This should be overridden per-machine to reflect the capabilities of the GL
17# stack.
18PACKAGECONFIG ??= "glx"
19
20# libx11 requires x11 in DISTRO_FEATURES.
21REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'glx', 'x11', '', d)}"
22
23# I say virtual/libgl, actually wants gl.pc
24PACKAGECONFIG[glx] = "-Dwaffle_has_glx=1,-Dwaffle_has_glx=0,virtual/libgl libx11"
25
26# I say virtual/libgl, actually wants wayland-egl.pc, egl.pc, and the wayland
27# DISTRO_FEATURE.
28PACKAGECONFIG[wayland] = "-Dwaffle_has_wayland=1,-Dwaffle_has_wayland=0,virtual/libgl wayland"
29
30# I say virtual/libgl, actually wants gbm.pc egl.pc
31PACKAGECONFIG[gbm] = "-Dwaffle_has_gbm=1,-Dwaffle_has_gbm=0,virtual/libgl udev"
32
33# I say virtual/libgl, actually wants egl.pc
34PACKAGECONFIG[x11-egl] = "-Dwaffle_has_x11_egl=1,-Dwaffle_has_x11_egl=0,virtual/libgl libxcb"
35
36FILES_${PN}-dev += "${datadir}/cmake/Modules/FindWaffle.cmake \
37 ${libdir}/cmake/Waffle/"