diff options
author | Wang Mingyu <wangmy@fujitsu.com> | 2024-07-29 09:09:59 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2024-08-03 07:47:36 +0100 |
commit | 7fb3424fd1e360043aa2a60b26c38e44eff23d68 (patch) | |
tree | 75968d31bad071a38760a39994373b4c0736ed6d /meta/recipes-graphics/spir/spirv-tools_1.3.290.0.bb | |
parent | 42920dd8d87255f98fe367bebefbf38e7825fc89 (diff) | |
download | poky-7fb3424fd1e360043aa2a60b26c38e44eff23d68.tar.gz |
spirv-tools: upgrade 1.3.283.0 -> 1.3.290.0
Changelog:
==========
- Do not fold mul and adds to generate fmas
- add OpExtInst forward ref fixup pass
- Separate Location check for tess patch
- Validate MemoryAccessMask of OpCooperativeMatrixStoreKHR
- OpSampledImage extra validation
- add support for OpExtInstWithForwardRefs
- add decorations to comments
- Add --nested-indent and --reorder-blocks
(From OE-Core rev: 0276f8aab4b688bbd0509513b0953628ca878584)
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/spir/spirv-tools_1.3.290.0.bb')
-rw-r--r-- | meta/recipes-graphics/spir/spirv-tools_1.3.290.0.bb | 47 |
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-graphics/spir/spirv-tools_1.3.290.0.bb b/meta/recipes-graphics/spir/spirv-tools_1.3.290.0.bb new file mode 100644 index 0000000000..1270da5b85 --- /dev/null +++ b/meta/recipes-graphics/spir/spirv-tools_1.3.290.0.bb | |||
@@ -0,0 +1,47 @@ | |||
1 | SUMMARY = "The SPIR-V Tools project provides an API and commands for \ | ||
2 | processing SPIR-V modules" | ||
3 | DESCRIPTION = "The project includes an assembler, binary module parser, \ | ||
4 | disassembler, validator, and optimizer for SPIR-V." | ||
5 | HOMEPAGE = "https://github.com/KhronosGroup/SPIRV-Tools" | ||
6 | SECTION = "graphics" | ||
7 | LICENSE = "Apache-2.0" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | ||
9 | |||
10 | SRCREV = "0cfe9e7219148716dfd30b37f4d21753f098707a" | ||
11 | SRC_URI = "git://github.com/KhronosGroup/SPIRV-Tools.git;branch=main;protocol=https" | ||
12 | PE = "1" | ||
13 | # These recipes need to be updated in lockstep with each other: | ||
14 | # glslang, vulkan-headers, vulkan-loader, vulkan-tools, spirv-headers, spirv-tools | ||
15 | # vulkan-validation-layers, vulkan-utility-libraries, vulkan-volk. | ||
16 | # The tags versions should always be sdk-x.y.z, as this is what | ||
17 | # upstream considers a release. | ||
18 | UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)" | ||
19 | S = "${WORKDIR}/git" | ||
20 | |||
21 | inherit cmake | ||
22 | |||
23 | DEPENDS = "spirv-headers" | ||
24 | |||
25 | EXTRA_OECMAKE += "\ | ||
26 | -DSPIRV-Headers_SOURCE_DIR=${STAGING_EXECPREFIXDIR} \ | ||
27 | -DSPIRV_TOOLS_BUILD_STATIC=OFF \ | ||
28 | -DBUILD_SHARED_LIBS=ON \ | ||
29 | -DSPIRV_SKIP_TESTS=ON \ | ||
30 | " | ||
31 | |||
32 | do_install:append:class-target() { | ||
33 | # Properly set _IMPORT_PREFIX in INTERFACE_LINK_LIBRARIES so that dependent | ||
34 | # tools can find the right library | ||
35 | sed -i ${D}${libdir}/cmake/SPIRV-Tools/SPIRV-ToolsTarget.cmake \ | ||
36 | -e 's:INTERFACE_LINK_LIBRARIES.*$:INTERFACE_LINK_LIBRARIES "\$\{_IMPORT_PREFIX\}/${baselib}":' | ||
37 | } | ||
38 | |||
39 | # all the libraries are unversioned, so don't pack it on PN-dev | ||
40 | SOLIBS = ".so" | ||
41 | FILES_SOLIBSDEV = "" | ||
42 | |||
43 | PACKAGES =+ "${PN}-lesspipe" | ||
44 | FILES:${PN}-lesspipe = "${base_bindir}/spirv-lesspipe.sh" | ||
45 | RDEPENDS:${PN}-lesspipe += "${PN} bash" | ||
46 | |||
47 | BBCLASSEXTEND = "native nativesdk" | ||