summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/pango/pango_1.50.11.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-11-07 15:54:59 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-11-08 22:47:16 +0000
commitf9e9707ed8c943d34293f968ae30608efc9b0919 (patch)
treee5d54aa19eb6a04b48323dda0d6bf2072c319f6a /meta/recipes-graphics/pango/pango_1.50.11.bb
parent11e54f1ff49f8c43fbd429b82931cdf3fff181f5 (diff)
downloadpoky-f9e9707ed8c943d34293f968ae30608efc9b0919.tar.gz
pango: upgrade 1.50.10 -> 1.50.11
(From OE-Core rev: a330e75f90841cd230180d8a9b37e58d7d69c495) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/pango/pango_1.50.11.bb')
-rw-r--r--meta/recipes-graphics/pango/pango_1.50.11.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta/recipes-graphics/pango/pango_1.50.11.bb b/meta/recipes-graphics/pango/pango_1.50.11.bb
new file mode 100644
index 0000000000..f545689811
--- /dev/null
+++ b/meta/recipes-graphics/pango/pango_1.50.11.bb
@@ -0,0 +1,60 @@
1SUMMARY = "Framework for layout and rendering of internationalized text"
2DESCRIPTION = "Pango is a library for laying out and rendering of text, \
3with an emphasis on internationalization. Pango can be used anywhere \
4that text layout is needed, though most of the work on Pango so far has \
5been done in the context of the GTK+ widget toolkit. Pango forms the \
6core of text and font handling for GTK+-2.x."
7HOMEPAGE = "http://www.pango.org/"
8BUGTRACKER = "http://bugzilla.gnome.org"
9SECTION = "libs"
10LICENSE = "LGPL-2.0-or-later"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7"
13
14GNOMEBASEBUILDCLASS = "meson"
15
16inherit gnomebase gi-docgen ptest-gnome upstream-version-is-even gobject-introspection
17
18UPSTREAM_CHECK_REGEX = "pango-(?P<pver>\d+\.(?!9\d+)\d+\.\d+)"
19
20GIR_MESON_ENABLE_FLAG = "enabled"
21GIR_MESON_DISABLE_FLAG = "disabled"
22
23SRC_URI += "file://run-ptest \
24 file://0001-Skip-running-test-layout-test.patch \
25"
26
27SRC_URI[archive.sha256sum] = "8800f812d89ee61388188703203f3a7878963c22f8695aaf1fa0a1a1428d17ae"
28
29DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz fribidi"
30
31PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)} \
32 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
33
34PACKAGECONFIG[x11] = ",,virtual/libx11 libxft"
35PACKAGECONFIG[tests] = "-Dinstall-tests=true, -Dinstall-tests=false"
36PACKAGECONFIG[thai] = ",,libthai"
37
38GIR_MESON_OPTION = 'introspection'
39
40do_configure:prepend() {
41 chmod +x ${S}/tests/*.py
42}
43
44# https://gitlab.gnome.org/GNOME/pango/-/issues/713
45do_install:append() {
46 mkdir -p ${D}/${libexecdir}/installed-tests/pango/nofonts/
47 install ${S}/tests/nofonts/fonts.conf ${D}/${libexecdir}/installed-tests/pango/nofonts/
48}
49
50LEAD_SONAME = "libpango-1.0*"
51
52FILES:${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"
53
54RDEPENDS:${PN}-ptest += "cantarell-fonts"
55RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-en-us"
56
57RPROVIDES:${PN} += "pango-modules pango-module-indic-lang \
58 pango-module-basic-fc pango-module-arabic-lang"
59
60BBCLASSEXTEND = "native nativesdk"