summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa-dri-glsl-native_8.0.4.bb
diff options
context:
space:
mode:
authorDamien Lespiau <damien.lespiau@intel.com>2012-08-02 17:49:00 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-06 15:18:52 +0100
commitc5084487eb7526323684e5389d28352c5787ebd2 (patch)
tree4b05a4ce6ae7425c469bf2edfe6f183921d25323 /meta/recipes-graphics/mesa/mesa-dri-glsl-native_8.0.4.bb
parentabfa907b4c4e682be63b82a14d5f0855d137e3c5 (diff)
downloadpoky-c5084487eb7526323684e5389d28352c5787ebd2.tar.gz
mesa: Update to 8.0.4 (latest stable version)
- The license file has changed, but the project still has the same license - Patches have been rebased on top of the 8.0 branch. crossfix.patch and crossfix-mklib.patch have been merged as they address the same problem (From OE-Core rev: e4039eb74b20e96d4b8837cd58cf2d13d091e1ad) Signed-off-by: Damien Lespiau <damien.lespiau@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa-dri-glsl-native_8.0.4.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa-dri-glsl-native_8.0.4.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-dri-glsl-native_8.0.4.bb b/meta/recipes-graphics/mesa/mesa-dri-glsl-native_8.0.4.bb
new file mode 100644
index 0000000000..a81fb6d035
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa-dri-glsl-native_8.0.4.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "gl shader language specific build from mesa-dri"
2HOMEPAGE = "http://mesa3d.org"
3BUGTRACKER = "https://bugs.freedesktop.org"
4SECTION = "x11"
5LICENSE = "GPLv3+"
6LIC_FILES_CHKSUM = "file://glsl_parser.cpp;beginline=3;endline=33;md5=d078f1cddc2fc355719c090482254bd9"
7
8DEPENDS = "makedepend-native"
9
10SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/${PV}/MesaLib-${PV}.tar.bz2"
11SRC_URI[md5sum] = "d546f988adfdf986cff45b1efa2d8a46"
12SRC_URI[sha256sum] = "02ed19f4f5f6535dda03a9932a81438aa78ea723ebba1f39a3d49a70a4e1d07e"
13
14S = "${WORKDIR}/Mesa-${PV}/src/glsl/"
15
16inherit native
17
18# use default config for native build
19do_configure_prepend() {
20 ln -sf ${S}/../../configs/default ${S}/../../configs/current
21}
22
23do_install() {
24 install -d ${D}/${bindir}/glsl
25 install -m 755 ${S}/builtin_compiler ${D}/${bindir}/glsl/builtin_compiler
26 install -m 755 ${S}/glsl_compiler ${D}/${bindir}/glsl/glsl_compiler
27}