summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa-demos_8.3.0.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-05-23 15:44:07 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-25 07:50:17 +0100
commitb5fe46044ea6324d66a7387c4f0d1d42fb418a70 (patch)
treea94aa707c4c2736287d9b12dd92d5d87566bdacd /meta/recipes-graphics/mesa/mesa-demos_8.3.0.bb
parent6ec08043dcabf62d0be9cfb43063b6a336c3ece3 (diff)
downloadpoky-b5fe46044ea6324d66a7387c4f0d1d42fb418a70.tar.gz
mesa-demos: Upgrade 8.2.0 -> 8.3.0
Drop patches included in upstream and the EGL_MESA_screen_surface extension fixes as the relevant code was removed. Rebase other patches. (From OE-Core rev: 747762233ee21eaaf480f19b85cd1d6543c7ca51) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa-demos_8.3.0.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa-demos_8.3.0.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-demos_8.3.0.bb b/meta/recipes-graphics/mesa/mesa-demos_8.3.0.bb
new file mode 100644
index 0000000000..ee0bb020a3
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa-demos_8.3.0.bb
@@ -0,0 +1,59 @@
1SUMMARY = "Mesa demo applications"
2DESCRIPTION = "This package includes the demonstration application, such as glxgears. \
3These applications can be used for Mesa validation and benchmarking."
4HOMEPAGE = "http://mesa3d.org"
5BUGTRACKER = "https://bugs.freedesktop.org"
6SECTION = "x11"
7
8LICENSE = "MIT & PD"
9LIC_FILES_CHKSUM = "file://src/xdemos/glxgears.c;beginline=1;endline=20;md5=914225785450eff644a86c871d3ae00e \
10 file://src/xdemos/glxdemo.c;beginline=1;endline=8;md5=b01d5ab1aee94d35b7efaa2ef48e1a06"
11
12SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/demos/${PV}/${BPN}-${PV}.tar.bz2 \
13 file://0001-mesa-demos-Add-missing-data-files.patch \
14 file://0003-configure-Allow-to-disable-demos-which-require-GLEW-.patch \
15 file://0004-Use-DEMOS_DATA_DIR-to-locate-data-files.patch \
16 file://0007-Install-few-more-test-programs.patch \
17 file://0008-glsl-perf-Add-few-missing-.glsl-.vert-.frag-files-to.patch \
18 file://0009-glsl-perf-Install-.glsl-.vert-.frag-files.patch \
19 file://0012-mesa-demos-OpenVG-demos-with-single-frame-need-eglSw.patch \
20 file://0013-only-build-GLX-demos-if-needed.patch \
21 "
22SRC_URI[md5sum] = "628e75c23c17394f11a316c36f8e4164"
23SRC_URI[sha256sum] = "c173154bbd0d5fb53d732471984def42fb1b14ac85fcb834138fb9518b3e0bef"
24
25inherit autotools pkgconfig distro_features_check
26# depends on virtual/egl, virtual/libgl ...
27REQUIRED_DISTRO_FEATURES = "opengl"
28
29PACKAGECONFIG ?= "drm osmesa freetype2 gbm egl gles1 gles2 \
30 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 glew glu glx', '', d)}"
31
32# The Wayland code doesn't work with Wayland 1.0, so disable it for now
33#${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}"
34
35EXTRA_OECONF = "--with-system-data-files"
36
37PACKAGECONFIG[drm] = "--enable-libdrm,--disable-libdrm,libdrm"
38PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl"
39PACKAGECONFIG[freetype2] = "--enable-freetype2,--disable-freetype2,freetype"
40PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm,virtual/libgl"
41PACKAGECONFIG[gles1] = "--enable-gles1,--disable-gles1,virtual/libgles1"
42PACKAGECONFIG[gles2] = "--enable-gles2,--disable-gles2,virtual/libgles2"
43PACKAGECONFIG[glut] = "--with-glut=${STAGING_EXECPREFIXDIR},--without-glut,"
44PACKAGECONFIG[osmesa] = "--enable-osmesa,--disable-osmesa,"
45PACKAGECONFIG[vg] = "--enable-vg,--disable-vg,virtual/libopenvg"
46PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,virtual/libgl wayland"
47PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11"
48PACKAGECONFIG[glew] = "--enable-glew,--disable-glew,glew"
49PACKAGECONFIG[glu] = "--enable-glu,--disable-glu,virtual/libgl"
50PACKAGECONFIG[glx] = "--enable-glx-demos,--disable-glx-demos"
51
52do_install_append() {
53 # it can be completely empty when all PACKAGECONFIG options are disabled
54 rmdir --ignore-fail-on-non-empty ${D}${bindir}
55
56 if [ -f ${D}${bindir}/clear ]; then
57 mv ${D}${bindir}/clear ${D}${bindir}/clear.mesa-demos
58 fi
59}