summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-05-23 15:44:07 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-25 07:50:17 +0100
commitb5fe46044ea6324d66a7387c4f0d1d42fb418a70 (patch)
treea94aa707c4c2736287d9b12dd92d5d87566bdacd /meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb
parent6ec08043dcabf62d0be9cfb43063b6a336c3ece3 (diff)
downloadpoky-b5fe46044ea6324d66a7387c4f0d1d42fb418a70.tar.gz
mesa-demos: Upgrade 8.2.0 -> 8.3.0
Drop patches included in upstream and the EGL_MESA_screen_surface extension fixes as the relevant code was removed. Rebase other patches. (From OE-Core rev: 747762233ee21eaaf480f19b85cd1d6543c7ca51) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb')
-rw-r--r--meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb64
1 files changed, 0 insertions, 64 deletions
diff --git a/meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb b/meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb
deleted file mode 100644
index 53bd5e2b41..0000000000
--- a/meta/recipes-graphics/mesa/mesa-demos_8.2.0.bb
+++ /dev/null
@@ -1,64 +0,0 @@
1SUMMARY = "Mesa demo applications"
2DESCRIPTION = "This package includes the demonstration application, such as glxgears. \
3These applications can be used for Mesa validation and benchmarking."
4HOMEPAGE = "http://mesa3d.org"
5BUGTRACKER = "https://bugs.freedesktop.org"
6SECTION = "x11"
7
8LICENSE = "MIT & PD"
9LIC_FILES_CHKSUM = "file://src/xdemos/glxgears.c;beginline=1;endline=20;md5=914225785450eff644a86c871d3ae00e \
10 file://src/xdemos/glxdemo.c;beginline=1;endline=8;md5=b01d5ab1aee94d35b7efaa2ef48e1a06"
11
12SRC_URI = "ftp://ftp.freedesktop.org/pub/mesa/demos/${PV}/${BPN}-${PV}.tar.bz2 \
13 file://0001-mesa-demos-Add-missing-data-files.patch \
14 file://0002-Correctly-implement-with-AC_WITH-glut-so-that-withou.patch \
15 file://0003-configure-Allow-to-disable-demos-which-require-GLEW-.patch \
16 file://0004-Use-DEMOS_DATA_DIR-to-locate-data-files.patch \
17 file://0005-Fix-build-when-EGL_MESA_screen_surface-extension-isn.patch \
18 file://0006-Query-display-for-EGL_MESA_screen_surface-extension-.patch \
19 file://0007-Install-few-more-test-programs.patch \
20 file://0008-glsl-perf-Add-few-missing-.glsl-.vert-.frag-files-to.patch \
21 file://0009-glsl-perf-Install-.glsl-.vert-.frag-files.patch \
22 file://0010-sharedtex_mt-fix-rendering-thread-hang.patch \
23 file://0011-drop-demos-dependant-on-obsolete-MESA_screen_surface.patch \
24 file://0012-mesa-demos-OpenVG-demos-with-single-frame-need-eglSw.patch \
25 file://0013-only-build-GLX-demos-if-needed.patch \
26"
27SRC_URI[md5sum] = "72613a2c8c013716db02e3ff59d29061"
28SRC_URI[sha256sum] = "e4bfecb5816ddd4b7b37c1bc876b63f1f7f06fda5879221a9774d0952f90ba92"
29
30inherit autotools pkgconfig distro_features_check
31# depends on virtual/egl, virtual/libgl ...
32REQUIRED_DISTRO_FEATURES = "opengl"
33
34PACKAGECONFIG ?= "drm osmesa freetype2 gbm egl gles1 gles2 \
35 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 glew glu glx', '', d)}"
36
37# The Wayland code doesn't work with Wayland 1.0, so disable it for now
38#${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}"
39
40EXTRA_OECONF = "--with-system-data-files"
41
42PACKAGECONFIG[drm] = "--enable-libdrm,--disable-libdrm,libdrm"
43PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl"
44PACKAGECONFIG[freetype2] = "--enable-freetype2,--disable-freetype2,freetype"
45PACKAGECONFIG[gbm] = "--enable-gbm,--disable-gbm,virtual/libgl"
46PACKAGECONFIG[gles1] = "--enable-gles1,--disable-gles1,virtual/libgles1"
47PACKAGECONFIG[gles2] = "--enable-gles2,--disable-gles2,virtual/libgles2"
48PACKAGECONFIG[glut] = "--with-glut=${STAGING_EXECPREFIXDIR},--without-glut,"
49PACKAGECONFIG[osmesa] = "--enable-osmesa,--disable-osmesa,"
50PACKAGECONFIG[vg] = "--enable-vg,--disable-vg,virtual/libopenvg"
51PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,virtual/libgl wayland"
52PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11"
53PACKAGECONFIG[glew] = "--enable-glew,--disable-glew,glew"
54PACKAGECONFIG[glu] = "--enable-glu,--disable-glu,virtual/libgl"
55PACKAGECONFIG[glx] = "--enable-glx-demos,--disable-glx-demos"
56
57do_install_append() {
58 # it can be completely empty when all PACKAGECONFIG options are disabled
59 rmdir --ignore-fail-on-non-empty ${D}${bindir}
60
61 if [ -f ${D}${bindir}/clear ]; then
62 mv ${D}${bindir}/clear ${D}${bindir}/clear.mesa-demos
63 fi
64}