summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.2.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-12-08 13:05:25 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-12-13 22:55:19 +0000
commit1417adcf53336bd65799f116f19237092a60d9c8 (patch)
treebb0dbd15b6565019d84621de8cd73fb81b9ed3e6 /meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.2.bb
parent8c1c43b7901a9fcd8b279eb4250b08157ad345b7 (diff)
downloadpoky-1417adcf53336bd65799f116f19237092a60d9c8.tar.gz
matchbox-wm: Upgrade 1.2.1 -> 1.2.2
Fixes [YOCTO #10635]: _NET_CURRENT_DESKTOP returns empty value. (From OE-Core rev: f63c75cc0da4f64ed2d769690122a34d40f7af49) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.2.bb')
-rw-r--r--meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.2.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.2.bb b/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.2.bb
new file mode 100644
index 0000000000..815a75f36d
--- /dev/null
+++ b/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.2.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Matchbox lightweight window manager"
2HOMEPAGE = "http://matchbox-project.org"
3BUGTRACKER = "http://bugzilla.yoctoproject.org/"
4
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://src/wm.h;endline=21;md5=a7e844465edbcf79c282369f93caa835 \
7 file://src/main.c;endline=21;md5=3e5d9f832b527b0d72dbe8e3c4c60b95 \
8 file://src/wm.c;endline=21;md5=8dc9d24477d87ef5dfbc2e4927146aab"
9
10SECTION = "x11/wm"
11DEPENDS = "libmatchbox virtual/libx11 libxext libxrender startup-notification expat gconf libxcursor libxfixes"
12
13# SRCREV tagged 1.2.2
14SRCREV = "27da947e7fbdf9659f7e5bd1e92af92af6c03970"
15SRC_URI = "git://git.yoctoproject.org/matchbox-window-manager \
16 file://kbdconfig"
17
18S = "${WORKDIR}/git"
19
20inherit autotools pkgconfig distro_features_check
21# depends on virtual/libx11
22REQUIRED_DISTRO_FEATURES = "x11"
23
24FILES_${PN} = "${bindir}/* \
25 ${datadir}/matchbox \
26 ${sysconfdir}/matchbox \
27 ${datadir}/themes/blondie/matchbox \
28 ${datadir}/themes/Default/matchbox \
29 ${datadir}/themes/MBOpus/matchbox"
30
31EXTRA_OECONF = " --enable-startup-notification \
32 --disable-xrm \
33 --enable-expat \
34 --with-expat-lib=${STAGING_LIBDIR} \
35 --with-expat-includes=${STAGING_INCDIR}"
36
37do_install_prepend() {
38 install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
39}