summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.1.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-03-02 14:31:50 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-15 18:05:23 +0100
commit8e71c5838086c8d9ac6e50299576f85fde3a0737 (patch)
tree6e1a108aae2b03816da2b5289c49e15ed19a46e4 /meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.1.bb
parent8072c7020f61c5e1a6e28d254dd967649e5a70c4 (diff)
downloadpoky-8e71c5838086c8d9ac6e50299576f85fde3a0737.tar.gz
matchbox-wm: Upgrade to 1.2.1
New version does not change MBWM theme when the Gtk+ theme is changed using Net/ThemeName X property. (From OE-Core rev: 840be4a11c376e336738858ae879bf0e97894684) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.1.bb')
-rw-r--r--meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.1.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.1.bb b/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.1.bb
new file mode 100644
index 0000000000..c3d2d23db5
--- /dev/null
+++ b/meta/recipes-graphics/matchbox-wm/matchbox-wm_1.2.1.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Matchbox lightweight window manager"
2HOMEPAGE = "http://matchbox-project.org"
3BUGTRACKER = "http://bugzilla.yoctoproject.org/"
4
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://src/wm.h;endline=21;md5=a7e844465edbcf79c282369f93caa835 \
7 file://src/main.c;endline=21;md5=3e5d9f832b527b0d72dbe8e3c4c60b95 \
8 file://src/wm.c;endline=21;md5=8dc9d24477d87ef5dfbc2e4927146aab"
9
10SECTION = "x11/wm"
11DEPENDS = "libmatchbox virtual/libx11 libxext libxrender startup-notification expat gconf libxcursor libxfixes"
12
13# SRCREV tagged 1.2.1
14SRCREV = "9fd1806dfa7c8f2202db18b7bc880857a3019f8c"
15SRC_URI = "git://git.yoctoproject.org/matchbox-window-manager \
16 file://kbdconfig"
17
18S = "${WORKDIR}/git"
19
20inherit autotools pkgconfig distro_features_check
21# depends on virtual/libx11
22REQUIRED_DISTRO_FEATURES = "x11"
23
24FILES_${PN} = "${bindir}/* \
25 ${datadir}/matchbox \
26 ${sysconfdir}/matchbox \
27 ${datadir}/themes/blondie/matchbox \
28 ${datadir}/themes/Default/matchbox \
29 ${datadir}/themes/MBOpus/matchbox"
30
31EXTRA_OECONF = " --enable-startup-notification \
32 --disable-xrm \
33 --enable-expat \
34 --with-expat-lib=${STAGING_LIBDIR} \
35 --with-expat-includes=${STAGING_INCDIR}"
36
37do_install_prepend() {
38 install ${WORKDIR}/kbdconfig ${S}/data/kbdconfig
39}