summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/libva/libva_2.1.0.bb
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2018-02-21 12:30:15 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-24 10:31:48 +0000
commit1226d1b737067fa7126a35db1c15e91e9263a3bb (patch)
treeb95517d851a988fd6506f928af4fccc7e5fbbb53 /meta/recipes-graphics/libva/libva_2.1.0.bb
parent4e3d3c122f95dd0a5735b3238a4d2072749d0d97 (diff)
downloadpoky-1226d1b737067fa7126a35db1c15e91e9263a3bb.tar.gz
libva: upgrade to 2.1.0
Major changes: * Bump VA-API version to 1.1.0 * Add API for multi-frame processing * Add entrypoint VAEntrypointStats for Statistics * Add data structures for HEVC FEI support * Add new attributes for decoding/encoding/video processing * Add new VPP filter for Total Color Correction * Add blending interface in VPP * Add rotation interface in VPP * Add mirroring interface in VPP * Add Chroma siting flags in VPP * Add new color standard definitions * Add new interface for exporting surface * Add message callbacks for drivers to use (From OE-Core rev: f8c01917594892be366580873618fa20272d2423) Signed-off-by: Anuj Mittal <anuj.mittal@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/libva/libva_2.1.0.bb')
-rw-r--r--meta/recipes-graphics/libva/libva_2.1.0.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-graphics/libva/libva_2.1.0.bb b/meta/recipes-graphics/libva/libva_2.1.0.bb
new file mode 100644
index 0000000000..d3cf6334ce
--- /dev/null
+++ b/meta/recipes-graphics/libva/libva_2.1.0.bb
@@ -0,0 +1,46 @@
1SUMMARY = "Video Acceleration (VA) API for Linux"
2DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
3and API specification which enables and provides access to graphics \
4hardware (GPU) acceleration for video processing on Linux and UNIX \
5based operating systems. Accelerated processing includes video \
6decoding, video encoding, subpicture blending and rendering. The \
7specification was originally designed by Intel for its GMA (Graphics \
8Media Accelerator) series of GPU hardware, the API is however not \
9limited to GPUs or Intel specific hardware, as other hardware and \
10manufacturers can also freely use this API for hardware accelerated \
11video decoding."
12
13HOMEPAGE = "https://01.org/linuxmedia/vaapi"
14BUGTRACKER = "https://github.com/intel/libva/issues"
15
16SECTION = "x11"
17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
19
20SRC_URI = "https://github.com/intel/${BPN}/releases/download/${PV}/${BP}.tar.bz2"
21
22SRC_URI[md5sum] = "9d6e4f1d36c407566343e9dde5a972b8"
23SRC_URI[sha256sum] = "f3fa953a11d3210c3a4ee79031abdbe0863d5ce13d9b3f93f315f1eec60a4b0f"
24
25UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases"
26
27DEPENDS = "libdrm virtual/mesa"
28
29inherit autotools pkgconfig distro_features_check
30
31REQUIRED_DISTRO_FEATURES = "opengl"
32
33EXTRA_OECONF = "ac_cv_prog_WAYLAND_SCANNER=wayland-scanner"
34
35PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
36PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxext libxfixes"
37PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland"
38
39PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"
40
41RDEPENDS_${PN}-x11 =+ "${PN}"
42RDEPENDS_${PN}-glx =+ "${PN}-x11"
43
44FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
45FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
46FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"