summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/jpeg/libjpeg-turbo_1.5.0.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2016-06-10 11:32:20 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-12 23:47:18 +0100
commit3332061f69ea03e1165f3c8b64197d3f35ffb95e (patch)
treea22e02ea3eda6b886f2968032dd5082005d80d7b /meta/recipes-graphics/jpeg/libjpeg-turbo_1.5.0.bb
parent4078b77e6e8287734ee70fad8d90b90302c391a9 (diff)
downloadpoky-3332061f69ea03e1165f3c8b64197d3f35ffb95e.tar.gz
libjpeg-turbo: update to 1.5.0
1. LIC_FILES_CHKSUM updates only involves changes in Copyright holders. LICENSE remains the same. 2. libjpeg-turbo don't have non-floating point ABI support in MIPS. Provide a work around for that. 3. Provide a workaround if Altivec unit is not present in PPC 4. Rename the recipe to fix upstream version check [YOCTO #9606] (From OE-Core rev: 46708da7a69ce4d4b0709abe6b694d7f0bd4deb5) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/jpeg/libjpeg-turbo_1.5.0.bb')
-rw-r--r--meta/recipes-graphics/jpeg/libjpeg-turbo_1.5.0.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-graphics/jpeg/libjpeg-turbo_1.5.0.bb b/meta/recipes-graphics/jpeg/libjpeg-turbo_1.5.0.bb
new file mode 100644
index 0000000000..c9e70d73d2
--- /dev/null
+++ b/meta/recipes-graphics/jpeg/libjpeg-turbo_1.5.0.bb
@@ -0,0 +1,46 @@
1SUMMARY = "Hardware accelerated JPEG compression/decompression library"
2DESCRIPTION = "libjpeg-turbo is a derivative of libjpeg that uses SIMD instructions (MMX, SSE2, NEON) to accelerate baseline JPEG compression and decompression"
3HOMEPAGE = "http://libjpeg-turbo.org/"
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://cdjpeg.h;endline=13;md5=05bab7c7ad899d85bfba60da1a1271f2 \
7 file://jpeglib.h;endline=16;md5=f67d70e547a2662c079781c72f877f72 \
8 file://djpeg.c;endline=11;md5=b90b6d2b4119f9e5807cd273f525d2af \
9"
10DEPENDS = "nasm-native"
11
12SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz"
13SRC_URI[md5sum] = "3fc5d9b6a8bce96161659ae7a9939257"
14SRC_URI[sha256sum] = "9f397c31a67d2b00ee37597da25898b03eb282ccd87b135a50a69993b6a2035f"
15UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/libjpeg-turbo/files/"
16UPSTREAM_CHECK_REGEX = "/libjpeg-turbo/files/(?P<pver>(\d+[\.\-_]*)+)/"
17
18PE= "1"
19
20# Drop-in replacement for jpeg
21PROVIDES = "jpeg"
22RPROVIDES_${PN} += "jpeg"
23RREPLACES_${PN} += "jpeg"
24RCONFLICTS_${PN} += "jpeg"
25
26inherit autotools pkgconfig
27
28# Work around missing x32 ABI support
29EXTRA_OECONF_append_class-target = " ${@bb.utils.contains("TUNE_FEATURES", "mx32", "--without-simd", "", d)}"
30
31# Work around missing non-floating point ABI support in MIPS
32EXTRA_OECONF_append_class-target = " ${@bb.utils.contains("MIPSPKGSFX_FPU", "-nf", "--without-simd", "", d)}"
33
34# Provide a workaround if Altivec unit is not present in PPC
35EXTRA_OECONF_append_class-target_powerpc = "${@bb.utils.contains("TUNE_FEATURES", "altivec", "", "--without-simd", d)}"
36EXTRA_OECONF_append_class-target_powerpc64 = "${@bb.utils.contains("TUNE_FEATURES", "altivec", "", "--without-simd", d)}"
37
38PACKAGES =+ "jpeg-tools libturbojpeg"
39
40DESCRIPTION_jpeg-tools = "The jpeg-tools package includes client programs to access libjpeg functionality. These tools allow for the compression, decompression, transformation and display of JPEG files and benchmarking of the libjpeg library."
41FILES_jpeg-tools = "${bindir}/*"
42
43DESCRIPTION_libturbojpeg = "A SIMD-accelerated JPEG codec which provides only TurboJPEG APIs"
44FILES_libturbojpeg = "${libdir}/libturbojpeg.so.*"
45
46BBCLASSEXTEND = "native"