summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/harfbuzz/harfbuzz_2.7.2.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-09-02 23:13:13 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-03 09:44:30 +0100
commit20c0fb192d6c402c0f24129708b54873642bb020 (patch)
tree79440f1ce557a84c04f813756d5e994f60469c7d /meta/recipes-graphics/harfbuzz/harfbuzz_2.7.2.bb
parent9d52b6726db183a37c78d3648ed601846e6839fd (diff)
downloadpoky-20c0fb192d6c402c0f24129708b54873642bb020.tar.gz
harfbuzz: upgrade 2.7.1 -> 2.7.2
(From OE-Core rev: bed6bb319611b8f98e412ac44363a54ce990c28e) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/harfbuzz/harfbuzz_2.7.2.bb')
-rw-r--r--meta/recipes-graphics/harfbuzz/harfbuzz_2.7.2.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-graphics/harfbuzz/harfbuzz_2.7.2.bb b/meta/recipes-graphics/harfbuzz/harfbuzz_2.7.2.bb
new file mode 100644
index 0000000000..8416eb93d8
--- /dev/null
+++ b/meta/recipes-graphics/harfbuzz/harfbuzz_2.7.2.bb
@@ -0,0 +1,51 @@
1SUMMARY = "Text shaping library"
2DESCRIPTION = "HarfBuzz is an OpenType text shaping engine."
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/HarfBuzz"
4BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=HarfBuzz"
5SECTION = "libs"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://COPYING;md5=8f787620b7d3866d9552fd1924c07572 \
8 file://src/hb-ucd.cc;beginline=1;endline=15;md5=29d4dcb6410429195df67efe3382d8bc"
9
10UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases"
11UPSTREAM_CHECK_REGEX = "harfbuzz-(?P<pver>\d+(\.\d+)+).tar"
12
13SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.xz \
14 file://0001-Do-not-disable-introspection-in-cross-builds.patch \
15 file://0001-src-hb-gobject-enums.cc.tmpl-write-out-only-the-file.patch \
16 "
17SRC_URI[sha256sum] = "b8c048d7c2964a12f2c80deb6634dfc836b603dd12bf0d0a3df1627698e220ce"
18
19inherit meson pkgconfig lib_package gtk-doc gobject-introspection
20
21GIR_MESON_ENABLE_FLAG = 'enabled'
22GIR_MESON_DISABLE_FLAG = 'disabled'
23GTKDOC_MESON_ENABLE_FLAG = 'enabled'
24GTKDOC_MESON_DISABLE_FLAG = 'disabled'
25
26PACKAGECONFIG ??= "cairo fontconfig freetype glib icu"
27PACKAGECONFIG[cairo] = "-Dcairo=enabled,-Dcairo=disabled,cairo"
28PACKAGECONFIG[fontconfig] = "-Dfontconfig=enabled,-Dfontconfig=disabled,fontconfig"
29PACKAGECONFIG[freetype] = "-Dfreetype=enabled,-Dfreetype=disabled,freetype"
30PACKAGECONFIG[glib] = "-Dglib=enabled,-Dglib=disabled,glib-2.0"
31PACKAGECONFIG[graphite] = "-Dgraphite=enabled,-Dgraphite=disabled,graphite2"
32PACKAGECONFIG[icu] = "-Dicu=enabled,-Dicu=disabled,icu"
33
34PACKAGES =+ "${PN}-icu ${PN}-icu-dev ${PN}-subset"
35
36LEAD_SONAME = "libharfbuzz.so"
37
38do_install_append() {
39 # If no tools are installed due to PACKAGECONFIG then this directory is
40 #still installed, so remove it to stop packaging wanings.
41 rmdir --ignore-fail-on-non-empty ${D}${bindir}
42}
43
44FILES_${PN}-icu = "${libdir}/libharfbuzz-icu.so.*"
45FILES_${PN}-icu-dev = "${libdir}/libharfbuzz-icu.la \
46 ${libdir}/libharfbuzz-icu.so \
47 ${libdir}/pkgconfig/harfbuzz-icu.pc \
48"
49FILES_${PN}-subset = "${libdir}/libharfbuzz-subset.so.*"
50
51BBCLASSEXTEND = "native nativesdk"