summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/glew/glew_1.12.0.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-02-16 20:56:08 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-18 07:39:30 +0000
commitaea0746cbb7b9d286d12007bd7d2a346f27cfc62 (patch)
treedd79e69f7e95c85c162b8d0eb76af4c69c81175d /meta/recipes-graphics/glew/glew_1.12.0.bb
parent0b1c3240ad1c1880740e68312b28f5e83915bd44 (diff)
downloadpoky-aea0746cbb7b9d286d12007bd7d2a346f27cfc62.tar.gz
glew: rewrite to use upstream build system
Instead of patching in a whole new build system using autotools, use the makefile-based system in upstream with careful variable assignments so that it cross-compiles correctly. One small patch was required to stop an unavoidable strip. Upstream does have a cmake-based build but it's not used or supported by the maintainer, and is quite buggy (for example: doesn't version the libraries, fails to link to required libraries). (From OE-Core rev: c77d0dfa18b2467f8856571837e7007f8fcd9b20) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/glew/glew_1.12.0.bb')
-rw-r--r--meta/recipes-graphics/glew/glew_1.12.0.bb28
1 files changed, 21 insertions, 7 deletions
diff --git a/meta/recipes-graphics/glew/glew_1.12.0.bb b/meta/recipes-graphics/glew/glew_1.12.0.bb
index ef416ec257..f1707d6655 100644
--- a/meta/recipes-graphics/glew/glew_1.12.0.bb
+++ b/meta/recipes-graphics/glew/glew_1.12.0.bb
@@ -8,12 +8,8 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2ac251558de685c6b9478d89be3149c2"
8 8
9DEPENDS = "virtual/libx11 virtual/libgl libglu libxext libxi libxmu" 9DEPENDS = "virtual/libx11 virtual/libgl libglu libxext libxi libxmu"
10 10
11
12SRC_URI = "${SOURCEFORGE_MIRROR}/project/glew/glew/${PV}/glew-${PV}.tgz \ 11SRC_URI = "${SOURCEFORGE_MIRROR}/project/glew/glew/${PV}/glew-${PV}.tgz \
13 file://autotools.patch \ 12 file://no-strip.patch"
14 file://glew_fix_for_automake-1.12.patch \
15 file://fix-glew.pc-install.patch \
16 "
17 13
18SRC_URI[md5sum] = "01246c7ecd135d99be031aa63f86dca1" 14SRC_URI[md5sum] = "01246c7ecd135d99be031aa63f86dca1"
19SRC_URI[sha256sum] = "af58103f4824b443e7fa4ed3af593b8edac6f3a7be3b30911edbc7344f48e4bf" 15SRC_URI[sha256sum] = "af58103f4824b443e7fa4ed3af593b8edac6f3a7be3b30911edbc7344f48e4bf"
@@ -21,6 +17,24 @@ SRC_URI[sha256sum] = "af58103f4824b443e7fa4ed3af593b8edac6f3a7be3b30911edbc7344f
21UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/glew/files/glew" 17UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/glew/files/glew"
22UPSTREAM_CHECK_REGEX = "/glew/(?P<pver>(\d+[\.\-_]*)+)/" 18UPSTREAM_CHECK_REGEX = "/glew/(?P<pver>(\d+[\.\-_]*)+)/"
23 19
24inherit autotools lib_package pkgconfig distro_features_check 20inherit lib_package pkgconfig distro_features_check
25# depends on virtual/libx11 21
26REQUIRED_DISTRO_FEATURES = "x11" 22REQUIRED_DISTRO_FEATURES = "x11"
23
24# Override SYSTEM to avoid calling config.guess, we're cross-compiling. Pass
25# our CFLAGS via POPT as that's the optimisation variable and safely
26# overwritten.
27EXTRA_OEMAKE = "SYSTEM='linux' \
28 CC='${CC}' LD='${CC}' STRIP='' \
29 LDFLAGS.EXTRA='${LDFLAGS}' \
30 POPT='${CFLAGS}' \
31 GLEW_PREFIX='${prefix}' BINDIR='${bindir}' \
32 LIBDIR='${libdir}' INCDIR='${includedir}/GL'"
33
34do_compile() {
35 oe_runmake
36}
37
38do_install() {
39 oe_runmake 'DESTDIR=${D}' install.all
40}