summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/fstests/fstests_git.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-12-05 16:18:47 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-05 16:27:13 +0000
commit0b962a5f4bfe54ec3a2ab66045a4155dfa9437ba (patch)
treeab4f3921146f525f276f7313e1273d6da0f43800 /meta/recipes-graphics/fstests/fstests_git.bb
parent67212c2a069b46049f2f503a839f8f791aae3342 (diff)
downloadpoky-0b962a5f4bfe54ec3a2ab66045a4155dfa9437ba.tar.gz
fstests: update to git master
Upstream git has a fix for broken compilation against Freetype 2.5.1. It also integrates the link patch we had, and installs into $bindir. (From OE-Core rev: 7fcfd0c001431683a82615c2a2fc241ca02a6af9) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/fstests/fstests_git.bb')
-rw-r--r--meta/recipes-graphics/fstests/fstests_git.bb14
1 files changed, 3 insertions, 11 deletions
diff --git a/meta/recipes-graphics/fstests/fstests_git.bb b/meta/recipes-graphics/fstests/fstests_git.bb
index 3d271ad54a..678d1e7ba0 100644
--- a/meta/recipes-graphics/fstests/fstests_git.bb
+++ b/meta/recipes-graphics/fstests/fstests_git.bb
@@ -4,21 +4,13 @@ SECTION = "devel"
4LICENSE = "Zlib" 4LICENSE = "Zlib"
5DEPENDS = "pango libxext libxft virtual/libx11 gtk+" 5DEPENDS = "pango libxext libxft virtual/libx11 gtk+"
6 6
7SRCREV = "218b99d82b56011e3f1b909e6baf22ce25af6334" 7SRCREV = "e5939ff608b95cdd4d0ab0e1935781ab9a276ac0"
8PV = "0.1+git${SRCPV}" 8PV = "0.1+git${SRCPV}"
9 9
10SRC_URI = "git://git.yoctoproject.org/${BPN}"
10 11
11SRC_URI = "git://git.yoctoproject.org/${BPN} \ 12LIC_FILES_CHKSUM = "file://test-pango-gdk.c;endline=24;md5=1ee74ec851ecda57eb7ac6cc180f7655"
12 file://dso_linking_change_build_fix.patch"
13 13
14S = "${WORKDIR}/git/tests" 14S = "${WORKDIR}/git/tests"
15 15
16inherit autotools 16inherit autotools
17
18do_install() {
19 install -d ${D}${bindir}
20 find . -name "test-*" -type f -perm -755 -exec install -m 0755 {} ${D}${bindir} \;
21}
22
23
24LIC_FILES_CHKSUM = "file://test-pango-gdk.c;endline=24;md5=1ee74ec851ecda57eb7ac6cc180f7655"