summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/freetype/freetype_2.6.5.bb
diff options
context:
space:
mode:
authorJussi Kukkonen <jussi.kukkonen@intel.com>2016-07-13 15:54:06 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-20 10:28:48 +0100
commit54d500947d7e061f3078d8e9de0cc79eac457d31 (patch)
tree174065555b7a5f357083e640e08ff7a63e942f79 /meta/recipes-graphics/freetype/freetype_2.6.5.bb
parent0a98691289b91ed8823adbce7e6e1ea0cb6fa7c0 (diff)
downloadpoky-54d500947d7e061f3078d8e9de0cc79eac457d31.tar.gz
freetype: Upgrade 2.6.3 -> 2.6.5
A new supposedly superior subpixel hinting mode was added and made default in 2.6.4 but 2.6.5 reverts the default to "no hinting". License checksum changes because of a copyright symbol change. (From OE-Core rev: 1494f9163ee4f866f9ccb6347038bf3ec205dfe3) Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/freetype/freetype_2.6.5.bb')
-rw-r--r--meta/recipes-graphics/freetype/freetype_2.6.5.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-graphics/freetype/freetype_2.6.5.bb b/meta/recipes-graphics/freetype/freetype_2.6.5.bb
new file mode 100644
index 0000000000..b8cac1c5c3
--- /dev/null
+++ b/meta/recipes-graphics/freetype/freetype_2.6.5.bb
@@ -0,0 +1,49 @@
1SUMMARY = "Freetype font rendering library"
2DESCRIPTION = "FreeType is a software font engine that is designed to be small, efficient, \
3highly customizable, and portable while capable of producing high-quality output (glyph \
4images). It can be used in graphics libraries, display servers, font conversion tools, text \
5image generation tools, and many other products as well."
6HOMEPAGE = "http://www.freetype.org/"
7BUGTRACKER = "https://savannah.nongnu.org/bugs/?group=freetype"
8SECTION = "libs"
9
10LICENSE = "FreeType | GPLv2+"
11LIC_FILES_CHKSUM = "file://docs/LICENSE.TXT;md5=4af6221506f202774ef74f64932878a1 \
12 file://docs/FTL.TXT;md5=13b25413274c9b3b09b63e4028216ff4 \
13 file://docs/GPLv2.TXT;md5=8ef380476f642c20ebf40fecb0add2ec"
14
15SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
16 file://use-right-libtool.patch"
17
18UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/freetype/files/freetype2/"
19UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)"
20
21SRC_URI[md5sum] = "6a386964e18ba28cb93370e57a19031b"
22SRC_URI[sha256sum] = "e20a6e1400798fd5e3d831dd821b61c35b1f9a6465d6b18a53a9df4cf441acf0"
23
24inherit autotools pkgconfig binconfig-disabled multilib_header
25
26# Adapt autotools to work with the minimal autoconf usage in freetype
27AUTOTOOLS_SCRIPT_PATH = "${S}/builds/unix"
28CONFIGURE_SCRIPT = "${S}/configure"
29EXTRA_AUTORECONF += "--exclude=autoheader --exclude=automake"
30
31PACKAGECONFIG ??= "zlib"
32
33PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2"
34# harfbuzz results in a circular dependency so enabling is non-trivial
35PACKAGECONFIG[harfbuzz] = "--with-harfbuzz,--without-harfbuzz,harfbuzz"
36PACKAGECONFIG[pixmap] = "--with-png,--without-png,libpng"
37PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
38
39EXTRA_OECONF = "CC_BUILD='${BUILD_CC}'"
40
41TARGET_CPPFLAGS += "-D_FILE_OFFSET_BITS=64"
42
43do_install_append() {
44 oe_multilib_header freetype2/freetype/config/ftconfig.h
45}
46
47BINCONFIG = "${bindir}/freetype-config"
48
49BBCLASSEXTEND = "native"