summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/freetype/freetype_2.10.2.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-05-14 23:28:51 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-05-15 16:31:44 +0100
commitff2a3335c432b6d031caf16d6b07e62f0743b9a3 (patch)
tree52673de4b43ce3a1235e1451cd4d69a406c984b3 /meta/recipes-graphics/freetype/freetype_2.10.2.bb
parentf468a73523811cbd869911a447f4ad3327062325 (diff)
downloadpoky-ff2a3335c432b6d031caf16d6b07e62f0743b9a3.tar.gz
freetype: upgrade 2.10.1 -> 2.10.2
(From OE-Core rev: 5d5adae33099101c86b00d29bcc1a2ecfb3a5888) Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/freetype/freetype_2.10.2.bb')
-rw-r--r--meta/recipes-graphics/freetype/freetype_2.10.2.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-graphics/freetype/freetype_2.10.2.bb b/meta/recipes-graphics/freetype/freetype_2.10.2.bb
new file mode 100644
index 0000000000..1034ddc0d7
--- /dev/null
+++ b/meta/recipes-graphics/freetype/freetype_2.10.2.bb
@@ -0,0 +1,47 @@
1SUMMARY = "Freetype font rendering library"
2DESCRIPTION = "FreeType is a software font engine that is designed to be small, efficient, \
3highly customizable, and portable while capable of producing high-quality output (glyph \
4images). It can be used in graphics libraries, display servers, font conversion tools, text \
5image generation tools, and many other products as well."
6HOMEPAGE = "http://www.freetype.org/"
7BUGTRACKER = "https://savannah.nongnu.org/bugs/?group=freetype"
8SECTION = "libs"
9
10LICENSE = "FreeType | GPLv2+"
11LIC_FILES_CHKSUM = "file://docs/LICENSE.TXT;md5=4af6221506f202774ef74f64932878a1 \
12 file://docs/FTL.TXT;md5=9f37b4e6afa3fef9dba8932b16bd3f97 \
13 file://docs/GPLv2.TXT;md5=8ef380476f642c20ebf40fecb0add2ec"
14
15SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/${BPN}/${BP}.tar.xz \
16 file://use-right-libtool.patch \
17 "
18SRC_URI[md5sum] = "7c0d5a39f232d7eb9f9d7da76bf08074"
19SRC_URI[sha256sum] = "1543d61025d2e6312e0a1c563652555f17378a204a61e99928c9fcef030a2d8b"
20
21UPSTREAM_CHECK_REGEX = "freetype-(?P<pver>\d+(\.\d+)+)"
22
23inherit autotools pkgconfig multilib_header
24
25# Adapt autotools to work with the minimal autoconf usage in freetype
26AUTOTOOLS_SCRIPT_PATH = "${S}/builds/unix"
27CONFIGURE_SCRIPT = "${S}/configure"
28EXTRA_AUTORECONF += "--exclude=autoheader --exclude=automake"
29
30PACKAGECONFIG ??= "zlib pixmap"
31
32PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2"
33# harfbuzz results in a circular dependency so enabling is non-trivial
34PACKAGECONFIG[harfbuzz] = "--with-harfbuzz,--without-harfbuzz,harfbuzz"
35PACKAGECONFIG[pixmap] = "--with-png,--without-png,libpng"
36PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
37PACKAGECONFIG[freetypeconfig] = "--enable-freetype-config=yes,--enable-freetype-config=no,"
38
39EXTRA_OECONF = "CC_BUILD='${BUILD_CC}'"
40
41TARGET_CPPFLAGS += "-D_FILE_OFFSET_BITS=64"
42
43do_install_append() {
44 oe_multilib_header freetype2/freetype/config/ftconfig.h
45}
46
47BBCLASSEXTEND = "native nativesdk"