summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/fontconfig/fontconfig_2.8.0.bb
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2012-05-28 08:47:58 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-05-30 12:04:46 +0100
commit7bf02ebc52cbe2a43e702034cda979746c9543aa (patch)
tree7e30c36a6b4a91cfe4f2f58ca4e5a4f72a826037 /meta/recipes-graphics/fontconfig/fontconfig_2.8.0.bb
parente8dac5a58a77d01d427add12617a7c01f412bcc4 (diff)
downloadpoky-7bf02ebc52cbe2a43e702034cda979746c9543aa.tar.gz
fontconfig: upgrade to 2.9.0
Other changes: - licence checksums because the licence headers changed slightly: several other authors were added and Keith Packard's name has been replaced with "author(s)". That's it. - rebased the fix-pkgconfig.patch to apply on 2.9.0 - removed all sed instructions in do_configure_append() that were changing fc-arch/Makefile. In the new version the fc-arch/ directory has been removed in order to make the package cross-compiling safe (From OE-Core rev: 8e219dea0373dc3a37d51f63c41f1a8449029dd5) Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/fontconfig/fontconfig_2.8.0.bb')
-rw-r--r--meta/recipes-graphics/fontconfig/fontconfig_2.8.0.bb93
1 files changed, 0 insertions, 93 deletions
diff --git a/meta/recipes-graphics/fontconfig/fontconfig_2.8.0.bb b/meta/recipes-graphics/fontconfig/fontconfig_2.8.0.bb
deleted file mode 100644
index 55c04cc909..0000000000
--- a/meta/recipes-graphics/fontconfig/fontconfig_2.8.0.bb
+++ /dev/null
@@ -1,93 +0,0 @@
1SUMMARY = "Generic font configuration library"
2DESCRIPTION = "Fontconfig is a font configuration and customization library, which \
3does not depend on the X Window System. It is designed to locate \
4fonts within the system and select them according to requirements \
5specified by applications. \
6Fontconfig is not a rasterization library, nor does it impose a \
7particular rasterization library on the application. The X-specific \
8library 'Xft' uses fontconfig along with freetype to specify and \
9rasterize fonts."
10
11HOMEPAGE = "http://www.fontconfig.org"
12BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=fontconfig"
13
14LICENSE = "MIT-style & MIT & PD"
15LIC_FILES_CHKSUM = "file://COPYING;md5=f3ad4145dea6ca7efa2f1bee8165a7a1 \
16 file://src/fcfreetype.c;endline=45;md5=bc3dd139e2f7245a02fde5545b203a6f \
17 file://src/fccache.c;beginline=1020;endline=1035;md5=0326cfeb4a7333dd4dd25fbbc4b9f27f"
18
19SECTION = "libs"
20
21DEPENDS = "expat freetype zlib"
22
23PR = "r4"
24
25SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz \
26 file://fix-pkgconfig.patch \
27 file://97_fontconfig"
28
29SRC_URI[md5sum] = "77e15a92006ddc2adbb06f840d591c0e"
30SRC_URI[sha256sum] = "fa2a1c6eea654d9fce7a4b1220f10c99cdec848dccaf1625c01f076b31382335"
31
32PACKAGES =+ "fontconfig-utils-dbg fontconfig-utils "
33FILES_fontconfig-utils-dbg = "${bindir}/*.dbg"
34FILES_fontconfig-utils = "${bindir}/*"
35
36# Work around past breakage in debian.bbclass
37RPROVIDES_fontconfig-utils = "libfontconfig-utils"
38RREPLACES_fontconfig-utils = "libfontconfig-utils"
39RCONFLICTS_fontconfig-utils = "libfontconfig-utils"
40DEBIAN_NOAUTONAME_fontconfig-utils = "1"
41
42PARALLEL_MAKE = ""
43
44inherit autotools pkgconfig
45
46export HASDOCBOOK="no"
47
48EXTRA_OECONF = " --disable-docs --with-arch=${HOST_ARCH} --with-default-fonts=${datadir}/fonts"
49EXTRA_OEMAKE = "FC_LANG=fc-lang FC_GLYPHNAME=fc-glyphname"
50
51# The tarball has some of the patched files as read only, which
52# patch doesn't like at all
53
54fontconfig_do_unpack() {
55 chmod -R u+rw ${S}
56}
57
58python do_unpack () {
59 bb.build.exec_func('base_do_unpack', d)
60 bb.build.exec_func('fontconfig_do_unpack', d)
61}
62
63BUILD_CFLAGS += " -I${STAGING_INCDIR}/freetype2"
64
65do_configure_append () {
66 sed -i 's|LDFLAGS =.*|LDFLAGS =|' fc-case/Makefile
67 sed -i 's|LDFLAGS =.*|LDFLAGS =|' fc-glyphname/Makefile
68 sed -i 's|LDFLAGS =.*|LDFLAGS =|' fc-lang/Makefile
69 sed -i 's|LDFLAGS =.*|LDFLAGS =|' fc-arch/Makefile
70
71 sed -i 's|CFLAGS =.*|CFLAGS =${BUILD_CFLAGS}|' fc-case/Makefile
72 sed -i 's|CFLAGS =.*|CFLAGS =${BUILD_CFLAGS}|' fc-glyphname/Makefile
73 sed -i 's|CFLAGS =.*|CFLAGS =${BUILD_CFLAGS}|' fc-lang/Makefile
74 sed -i 's|CFLAGS =.*|CFLAGS =${BUILD_CFLAGS}|' fc-arch/Makefile
75
76 sed -i 's|CPPFLAGS =.*|CPPFLAGS =${BUILD_CPPFLAGS}|' fc-case/Makefile
77 sed -i 's|CPPFLAGS =.*|CPPFLAGS =${BUILD_CPPFLAGS}|' fc-glyphname/Makefile
78 sed -i 's|CPPFLAGS =.*|CPPFLAGS =${BUILD_CPPFLAGS}|' fc-lang/Makefile
79 sed -i 's|CPPFLAGS =.*|CPPFLAGS =${BUILD_CPPFLAGS}|' fc-arch/Makefile
80
81 sed -i 's|CXXFLAGS =.*|CFLAGS =${BUILD_CXXFLAGS}|' fc-case/Makefile
82 sed -i 's|CXXFLAGS =.*|CFLAGS =${BUILD_CXXFLAGS}|' fc-glyphname/Makefile
83 sed -i 's|CXXFLAGS =.*|CFLAGS =${BUILD_CXXFLAGS}|' fc-lang/Makefile
84 sed -i 's|CXXFLAGS =.*|CFLAGS =${BUILD_CXXFLAGS}|' fc-arch/Makefile
85
86}
87
88do_install_append() {
89 install -d ${D}${sysconfdir}/default/volatiles
90 install -m 0644 ${WORKDIR}/97_fontconfig ${D}${sysconfdir}/default/volatiles
91 rmdir ${D}${localstatedir}/cache/fontconfig
92 rmdir ${D}${localstatedir}/cache/
93}