summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/fontconfig/fontconfig_2.12.6.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-10-10 15:02:27 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-09 12:33:17 +0000
commit0e8f5b62507c679ca1d14d4ca10e4900e77889c4 (patch)
tree42267c6ca93453e2246533f977f3e7c653e9dc14 /meta/recipes-graphics/fontconfig/fontconfig_2.12.6.bb
parentde57f3bca3acab60f445c43a07397c2b298d79a7 (diff)
downloadpoky-0e8f5b62507c679ca1d14d4ca10e4900e77889c4.tar.gz
fontconfig: update to 2.12.6
Add a patch to avoid crashing under qemu. (From OE-Core rev: da1d9898e953207a7649dfa765dd37eea9baf55d) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/fontconfig/fontconfig_2.12.6.bb')
-rw-r--r--meta/recipes-graphics/fontconfig/fontconfig_2.12.6.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta/recipes-graphics/fontconfig/fontconfig_2.12.6.bb b/meta/recipes-graphics/fontconfig/fontconfig_2.12.6.bb
new file mode 100644
index 0000000000..fa5f0eecc2
--- /dev/null
+++ b/meta/recipes-graphics/fontconfig/fontconfig_2.12.6.bb
@@ -0,0 +1,57 @@
1SUMMARY = "Generic font configuration library"
2DESCRIPTION = "Fontconfig is a font configuration and customization library, which \
3does not depend on the X Window System. It is designed to locate \
4fonts within the system and select them according to requirements \
5specified by applications. \
6Fontconfig is not a rasterization library, nor does it impose a \
7particular rasterization library on the application. The X-specific \
8library 'Xft' uses fontconfig along with freetype to specify and \
9rasterize fonts."
10
11HOMEPAGE = "http://www.fontconfig.org"
12BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=fontconfig"
13
14LICENSE = "MIT-style & MIT & PD"
15LIC_FILES_CHKSUM = "file://COPYING;md5=7a0449e9bc5370402a94c00204beca3d \
16 file://src/fcfreetype.c;endline=45;md5=5d9513e3196a1fbfdfa94051c09dfc84 \
17 file://src/fccache.c;beginline=1367;endline=1382;md5=0326cfeb4a7333dd4dd25fbbc4b9f27f"
18
19SECTION = "libs"
20
21DEPENDS = "expat freetype zlib gperf-native"
22
23SRC_URI = "http://fontconfig.org/release/fontconfig-${PV}.tar.gz \
24 file://revert-static-pkgconfig.patch \
25 file://0001-src-fcxml.c-avoid-double-free-of-filename.patch \
26 "
27
28SRC_URI[md5sum] = "00e748c67fad11e7057a71ed385e8bdb"
29SRC_URI[sha256sum] = "064b9ebf060c9e77011733ac9dc0e2ce92870b574cca2405e11f5353a683c334"
30
31
32do_configure_prepend() {
33 # work around https://bugs.freedesktop.org/show_bug.cgi?id=101280
34 rm -f ${S}/src/fcobjshash.h ${S}/src/fcobjshash.gperf
35}
36
37PACKAGES =+ "fontconfig-utils"
38FILES_${PN} =+ "${datadir}/xml/*"
39FILES_fontconfig-utils = "${bindir}/*"
40
41# Work around past breakage in debian.bbclass
42RPROVIDES_fontconfig-utils = "libfontconfig-utils"
43RREPLACES_fontconfig-utils = "libfontconfig-utils"
44RCONFLICTS_fontconfig-utils = "libfontconfig-utils"
45DEBIAN_NOAUTONAME_fontconfig-utils = "1"
46
47inherit autotools pkgconfig relative_symlinks
48
49FONTCONFIG_CACHE_DIR ?= "${localstatedir}/cache/fontconfig"
50
51# comma separated list of additional directories
52# /usr/share/fonts is already included by default (you can change it with --with-default-fonts)
53FONTCONFIG_FONT_DIRS ?= "no"
54
55EXTRA_OECONF = " --disable-docs --with-default-fonts=${datadir}/fonts --with-cache-dir=${FONTCONFIG_CACHE_DIR} --with-add-fonts=${FONTCONFIG_FONT_DIRS}"
56
57BBCLASSEXTEND = "native"